X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Эта тема была закрыта и архивирована. Если вам нужна помощь, задайте новый вопрос.

Firefox 66 still auto-plays videos

Размещено

I'm on Linux, and updated to Firefox 66 yesterday. I was looking forward to the new feature that disallows websites auto-playing videos. But I found that it's not the case. For example, https://www.bloomberg.com/news/articles/2019-03-19/how-an-extra-man-in-cockpit-saved-a-737-max-that-later-crashed still starts playing the video automatically. This is just one of the many I've tried so far.

Am I missing any settings? There was none I could find having done a quick search on the preference page.

I'm on Linux, and updated to Firefox 66 yesterday. I was looking forward to the new feature that disallows websites auto-playing videos. But I found that it's not the case. For example, https://www.bloomberg.com/news/articles/2019-03-19/how-an-extra-man-in-cockpit-saved-a-737-max-that-later-crashed still starts playing the video automatically. This is just one of the many I've tried so far. Am I missing any settings? There was none I could find having done a quick search on the preference page.

Выбранное решение

With these pref settings on the about:config page auto=play should be disabled.

  • media.autoplay.default = 1
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = true
Прочитайте этот ответ в контексте 1

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 32.0 r0

Приложение

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Дополнительная информация

badbanana 1 решений 6 ответов
Размещено

is it a misnomer that Firefox 66 is supposed to NOT auto play videos?

just updated to version 66, went to CNN and Fortune websites. lo and behold!! videos auto play!!

someone in mozilla jumped the gun on this feature?

is it a misnomer that Firefox 66 is supposed to NOT auto play videos? just updated to version 66, went to CNN and Fortune websites. lo and behold!! videos auto play!! someone in mozilla jumped the gun on this feature?
McCoy
  • Top 10 Contributor
545 решений 5139 ответов
Размещено

Hello jeenuv and badbanana,

Would you please take a look at these release notes :

See what's new in Firefox

When you scroll down to "new" you will see this :

"Firefox now prevents websites from automatically playing sound. You can add individual sites to an exceptions list or turn blocking off. To learn more about block autoplay, which will be rolled out gradually to all users, visit the Mozilla blog."

Hello jeenuv and badbanana, Would you please take a look at these release notes : [https://www.mozilla.org/en-US/firefox/66.0/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew See what's new in Firefox] When you scroll down to "new" you will see this : "Firefox now prevents websites from automatically playing sound. You can add individual sites to an exceptions list or turn blocking off. To learn more about block autoplay, '''which will be rolled out gradually to all users''', visit the Mozilla blog."
Размещено

Задавший вопрос

Now that you point out, I notice rolled out the part. The announcement gave the impression that it's ready to go.

So we are to expect 66.* versions soon, then?

Now that you point out, I notice '''rolled out''' the part. The announcement gave the impression that it's ready to go. So we are to expect 66.* versions soon, then?
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 решений 40227 ответов
Размещено

May or may not be in a 66.0.# 'chemspill' release, but IMO if that is done it wouldn't be for that feature alone - more than likely packaged with other 'necessary fixes' that would affect security or major breakage with other features. I base my opinion on how the "Form Autofill" feature was "rolled out" slowly - but that was a "system extension", so my guess may not be accurate.

In about:config you may want to take a look at the prefs that begin with - media.autoplay. - and see what is and isn't enabled. IMO that is where the "roll out" will tinker with the settings or features. Overall, my guess is that the next full version is where the "roll out" will continue ...

May or may not be in a 66.0.# 'chemspill' release, but IMO if that is done it wouldn't be for that feature alone - more than likely packaged with other 'necessary fixes' that would affect security or major breakage with other features. ''I base my opinion on how the "Form Autofill" feature was "rolled out" slowly - but that was a "system extension", so my guess may not be accurate.'' In '''about:config''' you may want to take a look at the prefs that begin with - '''''media.autoplay.''''' - and see what is and isn't enabled. IMO that is where the "roll out" will tinker with the settings or features. Overall, my guess is that the next full version is where the "roll out" will continue ...
cor-el
  • Top 10 Contributor
  • Moderator
17525 решений 158458 ответов
Размещено

Выбранное решение

With these pref settings on the about:config page auto=play should be disabled.

  • media.autoplay.default = 1
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = true
With these pref settings on the <b>about:config</b> page auto=play should be disabled. *media.autoplay.default = 1 *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = true

Изменено cor-el

cor-el
  • Top 10 Contributor
  • Moderator
17525 решений 158458 ответов
Размещено

This update seems to be about setting media.autoplay.default = 1 to block autoplay by default, so you will get a special icon at the left end of the location/address bar.

See also:

  • Bug 1535667 - Gradual rollout of block autoplay on release 66

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

(corrected the related bug report)

This update seems to be about setting media.autoplay.default = 1 to block autoplay by default, so you will get a special icon at the left end of the location/address bar. See also: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1535667 Bug 1535667] - Gradual rollout of block autoplay on release 66 (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>) ''(corrected the related bug report)''

Изменено cor-el

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 решений 40227 ответов
Размещено
'''''TIL''''' something new from Bug 1522923: https://wiki.mozilla.org/Firefox/Normandy/PreferenceRollout
koooper 4 решений 8 ответов
Размещено

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

To make the "stop autoplay" work again use these settings: media.autoplay.default: '''1''' media.autoplay.enabled.user-gestures-needed: '''false''' media.autoplay.allow-muted: '''false''' Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.
magnumquick 2 решений 15 ответов
Размещено

Tried all the manual fixes to stop autoplay, these fixes worked in 65.2 but not in 66.0 so until Mozilla fully releases the autoplay stop option I suggest re-installing 65.2 like I did, no autoplay now and I am a happy camper again.

Tried all the manual fixes to stop autoplay, these fixes worked in 65.2 but not in 66.0 so until Mozilla fully releases the autoplay stop option I suggest re-installing 65.2 like I did, no autoplay now and I am a happy camper again.
Размещено

Задавший вопрос

FWIW, the suggested options did work for me on FF66.

FWIW, the suggested options did work for me on FF66.
magnumquick 2 решений 15 ответов
Размещено

Полезный ответ

jeenuv said

FWIW, the suggested options did work for me on FF66.
Tried that but for some reason videos still autoplayed, I re-installed 65.0.2 and the settings worked for me. It's a crap shoot as to what will work for your particular system, I'll wait for the 67.0 update and see if it blocks autoplay.
''jeenuv [[#answer-1207562|said]]'' <blockquote> FWIW, the suggested options did work for me on FF66. </blockquote>Tried that but for some reason videos still autoplayed, I re-installed 65.0.2 and the settings worked for me. It's a crap shoot as to what will work for your particular system, I'll wait for the 67.0 update and see if it blocks autoplay.
teppscan 1 решений 6 ответов
Размещено

Полезный ответ

Please STOP posting and reposting the "about:config" instructions. THEY DO NOT WORK. I'm sick of seeing this repeated again and again and again.

Please STOP posting and reposting the "about:config" instructions. THEY DO NOT WORK. I'm sick of seeing this repeated again and again and again.
Dennis 0 решений 6 ответов
Размещено

None of the settings, except for muting the audio, still do not work. Audio is gone but the stupid videos still want to play. This is why I'm going back to my Firefox 58 instead of Firefox 68. I think Mozilla is getting kickbacks for us not being able to stop these videos from auto playing. A new version shouldn't change the workaround for the videos not playing. Seems like we have to go through this every time we take an update.

This is why I'm going back to my Firefox 58 instead of Firefox 68.

None of the settings, except for muting the audio, still do not work. Audio is gone but the stupid videos still want to play. This is why I'm going back to my Firefox 58 instead of Firefox 68. I think Mozilla is getting kickbacks for us not being able to stop these videos from auto playing. A new version shouldn't change the workaround for the videos not playing. Seems like we have to go through this every time we take an update. This is why I'm going back to my Firefox 58 instead of Firefox 68.