Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't disable session restore

  • 5 ответов
  • 1 имеет эту проблему
  • 44 просмотра
  • Последний ответ от cor-el

more options

Firefox Quantum 65.0; Windows 10 Pro; Grammarly, OneTab, RES, uBlock Origin

since about a week ago firefox always saves the open tabs and opens them after restarting the browser. It happens automatically and I can't stop firefox from doing so. I want every tab to be closed when I shut down firefox and they shouldn't automatically be reopened.

The box for Session Restore is unchecked and in about:config browser.sessionstore.max_resumed_crashes is set to zero and firefox still automatically restores the sessions

Приложенные скриншоты

Изменено Vulkanodox

Выбранное решение

Update/solution: There is a user.js file in my profile's folder. I did not create it. The firefox documentation states that it doesnt exist by default, it has to be created. http://kb.mozillazine.org/User.js_file

Content of the user.js file:

   user_pref("extensions.blocklist.enabled",false);
   user_pref("extensions.blocklist.interval",31536000);
   user_pref("extensions.blocklist.url","");
   user_pref("extensions.blocklist.itemURL","");
   user_pref("extensions.blocklist.detailsURL","");
   user_pref("security.mixed_content.block_active_content",false);
   user_pref("security.mixed_content.block_display_content",false);
   user_pref("app.update.staging.enabled",true);
   user_pref("browser.safebrowsing.appRepURL","");
   user_pref("app.update.silent",true);
   user_pref("browser.safebrowsing.updateURL","");
   user_pref("browser.safebrowsing.reportURL","");
   user_pref("browser.safebrowsing.reportMalwareURL","");
   user_pref("browser.safebrowsing.reportMalwareErrorURL","");
   user_pref("browser.safebrowsing.malware.reportURL","");
   user_pref("services.sync.prefs.sync.browser.safebrowsing.enabled",false);
   user_pref("services.sync.prefs.sync.browser.safebrowsing.malware.enabled",false);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);

and there is the problem. After deleting all the "user_pref("browser.sessionstore.resume_session_once", true);" lines but one and setting the remaining one to false my problem was solved. I guess some extension or plugin created this file and since it overrides any other change it didn't matter what setting I would change in the browser itself.

In the end, I set the user.js file to read-only to prevent this from happening again.

Прочитайте этот ответ в контексте 👍 0

Все ответы (5)

more options

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

FredMcD said

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder. Type about:support<enter> in the address bar. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory. Locate the above file. Then rename or delete it. Restart Firefox. Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

there are no sessionstore* files in this folder, only previous* and recovery*

more options

Выбранное решение

Update/solution: There is a user.js file in my profile's folder. I did not create it. The firefox documentation states that it doesnt exist by default, it has to be created. http://kb.mozillazine.org/User.js_file

Content of the user.js file:

   user_pref("extensions.blocklist.enabled",false);
   user_pref("extensions.blocklist.interval",31536000);
   user_pref("extensions.blocklist.url","");
   user_pref("extensions.blocklist.itemURL","");
   user_pref("extensions.blocklist.detailsURL","");
   user_pref("security.mixed_content.block_active_content",false);
   user_pref("security.mixed_content.block_display_content",false);
   user_pref("app.update.staging.enabled",true);
   user_pref("browser.safebrowsing.appRepURL","");
   user_pref("app.update.silent",true);
   user_pref("browser.safebrowsing.updateURL","");
   user_pref("browser.safebrowsing.reportURL","");
   user_pref("browser.safebrowsing.reportMalwareURL","");
   user_pref("browser.safebrowsing.reportMalwareErrorURL","");
   user_pref("browser.safebrowsing.malware.reportURL","");
   user_pref("services.sync.prefs.sync.browser.safebrowsing.enabled",false);
   user_pref("services.sync.prefs.sync.browser.safebrowsing.malware.enabled",false);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);
   user_pref("browser.sessionstore.resume_session_once", true);

and there is the problem. After deleting all the "user_pref("browser.sessionstore.resume_session_once", true);" lines but one and setting the remaining one to false my problem was solved. I guess some extension or plugin created this file and since it overrides any other change it didn't matter what setting I would change in the browser itself.

In the end, I set the user.js file to read-only to prevent this from happening again.

more options

That was very good work. Well done.

more options

If you didn't create the user.js file yourself then you should remove this file. It is likely added by other software without informing you.