Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

FF61: Settings -> General not shown (about:preferences#general). Other Settings work properly.

  • 3 ответа
  • 1 имеет эту проблему
  • 375 просмотров
  • Последний ответ от s-nightingale

more options

If I try to select the General topic in Settings it just doesn't switch over to display the appropriate entries. The last selected topic stays on the screen.

browser-console shows three entries when clicking on general:

NS_ERROR_FILE_ACCESS_DENIED: Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.create] FileUtils.jsm:67

Error initializing preference category paneGeneral: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 251" data: no] preferences.js:162 gotoPref chrome://browser/content/preferences/in-content/preferences.js:162:5 init_all/< chrome://browser/content/preferences/in-content/preferences.js:70:50 _fireOnSelect chrome://global/content/bindings/richlistbox.xml:78:13 selectItem chrome://global/content/bindings/listbox.xml:237:11 onxblmousedown chrome://global/content/bindings/listbox.xml:995:13

NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService] XPCOMUtils.jsm:251 XPCU_serviceLambda resource://gre/modules/XPCOMUtils.jsm:251:16 get resource://gre/modules/XPCOMUtils.jsm:183:21 get isPending chrome://browser/content/aboutDialog-appUpdater.js:114:5 appUpdater chrome://browser/content/aboutDialog-appUpdater.js:68:1 init chrome://browser/content/preferences/in-content/main.js:510:21 init chrome://browser/content/preferences/in-content/preferences.js:43:7 init_category_if_required chrome://browser/content/preferences/in-content/preferences.js:36:3 gotoPref chrome://browser/content/preferences/in-content/preferences.js:160:5 init_all/< chrome://browser/content/preferences/in-content/preferences.js:70:50 _fireOnSelect chrome://global/content/bindings/richlistbox.xml:78:13 selectItem chrome://global/content/bindings/listbox.xml:237:11 onxblmousedown chrome://global/content/bindings/listbox.xml:995:13

Выбранное решение

The cause of the problem was the maintainance-service not being properly installed or regonized or falsely configured.

However fixing the problem took me some investigation.

Solved it finally by -uninstalling ff and maintenance-service -moving profile-folders and profile.ini to a different place -installing ff (not the latest version) After that general settings still didn't show up but I was able to do an update via Help..About..Update (this button was unresponsive in the original problematic state). This lead me to a working update to the latest (there is no other choice in this procedure) ff-version .

Finally -moving back my saved profile-folders -some minor fixes on userChrome.css were needed

 (updating from ff61 to ff64)

did the job.

Calling "general setting" somehow tries to connect to the maintenance-service since it retrieves some information from that for displaying the update-options in this page. It failed with that and didn't show up at all. So this symptom was just a side-effect.

Also to mention: I've also tried starting the portable version of ff and it showed the same failure. Looks like there are some more system-settings involved other than the ff-profile.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Your error is saying Chrome how is that a firefox issue?

more options

Firefox 61.0.1 see picture attached

more options

Выбранное решение

The cause of the problem was the maintainance-service not being properly installed or regonized or falsely configured.

However fixing the problem took me some investigation.

Solved it finally by -uninstalling ff and maintenance-service -moving profile-folders and profile.ini to a different place -installing ff (not the latest version) After that general settings still didn't show up but I was able to do an update via Help..About..Update (this button was unresponsive in the original problematic state). This lead me to a working update to the latest (there is no other choice in this procedure) ff-version .

Finally -moving back my saved profile-folders -some minor fixes on userChrome.css were needed

 (updating from ff61 to ff64)

did the job.

Calling "general setting" somehow tries to connect to the maintenance-service since it retrieves some information from that for displaying the update-options in this page. It failed with that and didn't show up at all. So this symptom was just a side-effect.

Also to mention: I've also tried starting the portable version of ff and it showed the same failure. Looks like there are some more system-settings involved other than the ff-profile.