X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Firefox 64 blocking Flash games from saving

Размещено

I play Flash games on Kongregate every now and then, but - for whatever reason - Firefox 64 blocks them from saving.

They load OK but something (which must be a new setting that Firefox 64 added) is blocking them from saving new data, both automatically and when I manually click 'save' on games with this option. Nothing is writing to the Appdata folder where the game data is stored (stored as .sol files).

Never had the problem before, and everything works again if I revert to 63.0.3. Any ideas what could be causing it?

Many thanks in advance.

I play Flash games on Kongregate every now and then, but - for whatever reason - Firefox 64 blocks them from saving. They load OK but something (which must be a new setting that Firefox 64 added) is blocking them from saving new data, both automatically and when I manually click 'save' on games with this option. Nothing is writing to the Appdata folder where the game data is stored (stored as .sol files). Never had the problem before, and everything works again if I revert to 63.0.3. Any ideas what could be causing it? Many thanks in advance.

Выбранное решение

Hi Neilo, did you already find a solution?

Firefox 64 ratcheted up the Flash sandbox setting. Users on Kongregate forums indicated this is to blame, although it's not clear why.

To experiment with that setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) The dom.ipc.plugins.sandbox-level.flash preference restricts what Flash content can do on your system.

  • 1 - blocks "write access to most of the filesystem", "exec" and "fork"
  • 2 - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)"
  • 3 (default in Fx64) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)"

It seems that lowering the sandbox level to 2 can resolve the storage issue according to

Save failing since Firefox update discussion on Kongregate

(probably after exiting out of Firefox and starting it up again, or at least after reload the page)

but in another thread, some users still had issues. In that case, you might try 1 and see whether that resolves it.

Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: Why do I have to click to activate plugins?

Прочитайте этот ответ в контексте 1

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 31.0 r0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Дополнительная информация

jscher2000
  • Top 10 Contributor
8695 решений 71066 ответов
Размещено

Выбранное решение

Hi Neilo, did you already find a solution?

Firefox 64 ratcheted up the Flash sandbox setting. Users on Kongregate forums indicated this is to blame, although it's not clear why.

To experiment with that setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) The dom.ipc.plugins.sandbox-level.flash preference restricts what Flash content can do on your system.

  • 1 - blocks "write access to most of the filesystem", "exec" and "fork"
  • 2 - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)"
  • 3 (default in Fx64) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)"

It seems that lowering the sandbox level to 2 can resolve the storage issue according to

Save failing since Firefox update discussion on Kongregate

(probably after exiting out of Firefox and starting it up again, or at least after reload the page)

but in another thread, some users still had issues. In that case, you might try 1 and see whether that resolves it.

Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: Why do I have to click to activate plugins?

Hi Neilo, did you already find a solution? Firefox 64 ratcheted up the Flash sandbox setting. Users on Kongregate forums indicated this is to blame, although it's not clear why. To experiment with that setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''sand''' and pause while the list is filtered (3) The '''dom.ipc.plugins.sandbox-level.flash''' preference restricts what Flash content can do on your system. * '''1''' - blocks "write access to most of the filesystem", "exec" and "fork" * '''2''' - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)" * '''3''' (default in Fx64) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)" It seems that lowering the sandbox level to '''2''' can resolve the storage issue according to [https://www.kongregate.com/forums/8945-realm-grinder/topics/1783703-save-failing-since-firefox-update Save failing since Firefox update discussion on Kongregate] (probably after exiting out of Firefox and starting it up again, or at least after reload the page) but in another thread, some users still had issues. In that case, you might try '''1''' and see whether that resolves it. Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: [[Why do I have to click to activate plugins?]]
cor-el
  • Top 10 Contributor
  • Moderator
17473 решений 157940 ответов
Размещено

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode"