Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox 63 starts autoplay even when options does not allow this!

  • 7 ответов
  • 1 имеет эту проблему
  • 34 просмотра
  • Последний ответ от jscher2000

more options

Hello I've got problem with new version of Firefox (63.0.3 currently). The browser starts autoplay (videos, audio, gifs, etc.) even when setting in options does not allow this. Where is other option responsible for this bug? I mean other than set of autoplay settings (9 in new version). Please help, this is annoying!!!

Все ответы (7)

more options

I have these set this way and it works for me.

- media.autoplay.allow-muted: false - media.autoplay.ask-permission: true - media.autoplay.default:1 - media.autoplay.enabled.user-gestures-needed: true

more options

Hi Pathear, were you setting media.autoplay.enabled to false?

Note: this confirms the first reply and describes the preferences in more detail.

For Firefox 63

The old preference is obsolete. Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available in this "work in progress."

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)
more options

Thanks for your replies! I already know that starting from 63 Firefox enhanced autoplay options. I tried many different configurations till now and settings as in attachment are the best at the moment. But unfortunately it does not stop autoplay! Sometimes reloading of the page effect with media that should be stopped are starting automatically! It seems that these options in Firefox are not efficient. Is there any other option which is responsible for uncontrolled behavior of medias on the pages?

more options

Are there some sites where autoplay is blocked and other sites where it happens?

If autoplay happens only on a couple sites, could you give some example URLs?

If autoplay happens everywhere, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Unfortunately it don't helps. I expected new version of Firefox will be fixed but in v64 is the same situation - autoplay starts automatically regardless of settings configuration. It happens ocasionally, I mean when the page is reloaded the autostart can be blocked (as expected) or not - random? web-autoplay is quicker than Firefox is trying to block it? No idea what's going on... The same problem occurs on some different machines with new firefox installed. On earlier versions (lower than 63) it was all OK!

more options

Is it really necessary to downgrade and use old Firefox?

-((
more options

Hi Pathear, the only site anyone has mentioned that can autoplay with the new permission-based approach is Yahoo News. I think someone needs to look at that more closely and figure out how to stop it. Is that where you have the problem or are there other sites?