X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Firefox Quantum Uses an excessive amount of ram for Addons

Размещено

recently ever since upgrading to Firefox Quantum i have noticed a huge RAM issue and after looming around forums for many months gathering different viewpoints on this problem i feel like the issue is most likely being caused by the new addon handling protocols, once you disable every single addon you will notice firefox uses about 80% less ram, the problem isnt that i have too many addons even with a single addon enabled the RAM usage dramatically increases i personally only use an adblocker and google translator very lightweight addons for any other version of firefox until it hits Quantum, and no i dont use 100 tabs in a single session... i normally use like 2-3 tabs and have only about 8 tabs only max, but if that doesn't convince you at mozilla that Quantum has horrible addon handling take this into your figures Quantum without addons idles on a fresh restart at about 400mb RAM usage but once you enable an addon that number jumps up to about 500-600mb and every addon enabled after that compounds the usage issue

this wasn't a problem with firefox until quantum was introduced, and from what i hear about the firefox quantum the addon handling was changed to disallow addons access to specific browser system files that some addons were using that caused firefox to crash,

feel free to correct me if i'm wrong but “Once you have eliminated the impossible, whatever remains, however improbable, must be the truth.” iv eliminated all the other probable causes and the changes to the addon handling is all that remains

recently ever since upgrading to Firefox Quantum i have noticed a huge RAM issue and after looming around forums for many months gathering different viewpoints on this problem i feel like the issue is most likely being caused by the new addon handling protocols, once you disable every single addon you will notice firefox uses about 80% less ram, the problem isnt that i have too many addons even with a single addon enabled the RAM usage dramatically increases i personally only use an adblocker and google translator very lightweight addons for any other version of firefox until it hits Quantum, and no i dont use 100 tabs in a single session... i normally use like 2-3 tabs and have only about 8 tabs only max, but if that doesn't convince you at mozilla that Quantum has horrible addon handling take this into your figures Quantum without addons idles on a fresh restart at about 400mb RAM usage but once you enable an addon that number jumps up to about 500-600mb and every addon enabled after that compounds the usage issue this wasn't a problem with firefox until quantum was introduced, and from what i hear about the firefox quantum the addon handling was changed to disallow addons access to specific browser system files that some addons were using that caused firefox to crash, feel free to correct me if i'm wrong but “Once you have eliminated the impossible, whatever remains, however improbable, must be the truth.” iv eliminated all the other probable causes and the changes to the addon handling is all that remains

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 31.0 r0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Дополнительная информация

Chuckles71 1 решений 3 ответов
Размещено

Myself, no problems with RAM, but I do find that at times when using FirefOx, that my laptop slows to a crawl.

I'm not clear why as nothing is maxing out (CPU, Ram are fine), but it happens anyway.

Myself, no problems with RAM, but I do find that at times when using FirefOx, that my laptop slows to a crawl. I'm not clear why as nothing is maxing out (CPU, Ram are fine), but it happens anyway.
bornival 0 решений 18 ответов
Размещено

Hi, I have the same problem but here is what makes it worse. My desktop has 8 GB RAM and when FireFox runs, it eats easily 3 GB... Since the other applications use 4 GB, I'm at the limit but it still works. Now, my lap-top has only 4 GB RAM and when FireFox runs, there is not much RAM available... This appeared only with the Quantum. How can we limit the amount of RAM FireFox takes ?

Hi, I have the same problem but here is what makes it worse. My desktop has 8 GB RAM and when FireFox runs, it eats easily 3 GB... Since the other applications use 4 GB, I'm at the limit but it still works. Now, my lap-top has only 4 GB RAM and when FireFox runs, there is not much RAM available... This appeared only with the Quantum. How can we limit the amount of RAM FireFox takes ?
Pj 42 решений 869 ответов
Размещено

judess69er said

Ever since upgrading to Firefox Quantum, I have noticed a huge RAM issue and after looming around forums for many months gathering different viewpoints on this problem, I feel like the issue is most likely being caused by the new Add-on (Extension) handling protocols.

Once you disable every single Add-on, you will notice Firefox uses about 80% less ram. The problem isn't that I have too many Add-ons. Even with a single Add-on enabled, the RAM usage dramatically increases.

I personally only use an ad-blocker and Google translator - very lightweight Add-ons for any other version of Firefox until it hits Quantum, and no I don't use 100 tabs in a single session.

I normally use like 2-3 tabs and have only about 8 tabs only max, but if that doesn't convince you, at Mozilla, that Quantum has horrible Add-on handling, take this into your figures:

Quantum without Add-ons idles on a fresh restart at about 400mb RAM usage, but once you enable an Add-on, that number jumps up to about 500-600mb and every Add-on enabled after that compounds the usage issue.

This wasn't a problem with Firefox until quantum was introduced, and from what I hear about the Firefox Quantum, the Add-on handling was changed to disallow Add-ons access to specific browser system files that some Add-ons were using that caused Firefox to crash.

Feel free to correct me if I'm wrong, but “Once you have eliminated the impossible, whatever remains, however improbable, must be the truth.”

I've eliminated all the other probable causes and the changes to the Add-on handling is all that remains.

I see you using an older version of Flash. You probably should update that to the latest (...114). Also, FF 65 is supposed to be a bit better on Memory. You should update it also.

Which Ad-Blocker do you use? I had ABP (Ad-Blocker Plus) and found uBlock Origin to be more Memory-Friendly with my old computer (Nov 2010, 8GB RAM).

I do see in Task Manager, Physical Memory Usage over time creeps up the graph, eventually nearing my 8GB my computer has. So, depending how many Tabs/Sites I visit, when the Graph Line nears the top, I hear my disk drive go into 'crunch' mode. This must be FF Caching Data. This can happen within several days or 4 or 5 days later, depending on my FF use.

However, one it reaches this point, the browser performance takes a nasty hit. The only way to regain better performance for me, is to Exit (Quit) FF and restart it.

Please do this:

Click on the Windows icon 'Start' (bottom-left) and in the right column, bottom, click on Run. Enter in:

DxDiag /64bit

(Skip the /64bit part if it's Windows 32-Bit.)

...Wait until the green bar loads and disappears, then click "Save All Information".
Post back here in the Forum, just these information parts, under these three Headers:

    System Information
Display Devices
Disk & DVD/CD-ROM Drives

Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is TOO LOW!
Example: At the moment, I have 37% space free. If you're way under 25%, then you're probably running into performance / Memory issues.
Windows-7 and Programs like to have plenty of free-disk 'breathing' room. I recently cleared over 75 Gigs worth to get me to about 37% of free disk space.

Perhaps you may wish to setup a ReadyBoost Flash Drive.
If you have a lot of Windows and Tabs (ok, you said you don't, but for others that do...) and your FireFox Browser is set to Restore Session when you start-up FF, the following will help with conserving some Memory:

Go to Options. Edit or Insert in the URL Box About:Config and go there. Set the following Values:

browser.newtabpage.enabled; false

browser.newtabpage.enhanced; false

browser.sessionstore.restore_pinned_tabs_on_demand; true


This will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.

If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. My max is set for 25:

browser.sessionstore.max_windows_undo; 25

Additionally, you could try this also. Have FF reset how much Disk Cache it will use for your system by changing the following to true:

browser.cache.disk.smart_size.first_run - false

It will change back to false after FF is Exited and runs next time, setting-up your Disk Cache value. Maybe this doesn't need to run again, but I did it a while back and it 'appeared' to help me.

Finally, I did the following FireFox adjustments for my old 2010 computer with the Performance settings in Options as shown in the image attachment:

~Pj

''judess69er [[#question-1238564|said]]'' <blockquote> Ever since upgrading to Firefox Quantum, I have noticed a huge RAM issue and after looming around forums for many months gathering different viewpoints on this problem, I feel like the issue is most likely being caused by the new Add-on (Extension) handling protocols. <Br><Br> Once you disable every single Add-on, you will notice Firefox uses about 80% less ram. The problem isn't that I have too many Add-ons. Even with a single Add-on enabled, the RAM usage dramatically increases. <Br><Br> I personally only use an ad-blocker and Google translator - very lightweight Add-ons for any other version of Firefox until it hits Quantum, and no I don't use 100 tabs in a single session. <Br><Br> I normally use like 2-3 tabs and have only about 8 tabs only max, but if that doesn't convince you, at Mozilla, that Quantum has horrible Add-on handling, take this into your figures: <Br><Br> Quantum without Add-ons idles on a fresh restart at about 400mb RAM usage, but once you enable an Add-on, that number jumps up to about 500-600mb and every Add-on enabled after that compounds the usage issue. <Br><Br> This wasn't a problem with Firefox until quantum was introduced, and from what I hear about the Firefox Quantum, the Add-on handling was changed to disallow Add-ons access to specific browser system files that some Add-ons were using that caused Firefox to crash. <Br><Br> Feel free to correct me if I'm wrong, but “Once you have eliminated the impossible, whatever remains, however improbable, must be the truth.” <Br><Br> I've eliminated all the other probable causes and the changes to the Add-on handling is all that remains. </blockquote> I see you using an older version of Flash. You probably should update that to the latest (...114). Also, FF 65 is supposed to be a bit better on Memory. You should update it also. Which Ad-Blocker do you use? I had ABP (Ad-Blocker Plus) and found '''uBlock Origin''' to be more Memory-Friendly with my old computer (Nov 2010, 8GB RAM). <Br> I do see in Task Manager, '''Physical Memory Usage''' over time creeps up the graph, eventually nearing my 8GB my computer has. So, depending how many Tabs/Sites I visit, when the Graph Line nears the top, I hear my disk drive go into 'crunch' mode. This must be FF Caching Data. This can happen within several days or 4 or 5 days later, depending on my FF use. <Br> However, one it reaches this point, the browser performance takes a nasty hit. The only way to regain better performance for me, is to Exit (Quit) FF and restart it. <Br> Please do this: <Br> Click on the Windows icon ''''Start'''' (bottom-left) and in the right column, bottom, click on '''Run'''. Enter in: <Center>'''DxDiag /64bit'''</Center><Br> <Center> (Skip the '''/64bit''' part if it's Windows 32-Bit.)</Center><Br> ...Wait until the green bar loads and disappears, then click "'''Save All Information'''". <Br> Post back here in the Forum, just these information parts, under these three Headers:<Br> '''System Information'''<Br> '''Display Devices'''<Br> '''Disk & DVD/CD-ROM Drives'''<Br> Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is '''TOO LOW!'''<Br> Example: At the moment, I have 37% space free. If you're way under 25%, then you're probably running into performance / Memory issues.<Br> Windows-7 and Programs like to have plenty of free-disk 'breathing' room. I recently cleared over 75 Gigs worth to get me to about 37% of free disk space.<Br><Br> Perhaps you may wish to setup a '''ReadyBoost''' Flash Drive.<Br> If you have a lot of Windows and Tabs (ok, you said you don't, but for others that do...) and your FireFox Browser is set to '''Restore Session''' when you start-up FF, the following will help with conserving some Memory:<Br><Br> Go to '''Options'''. Edit or Insert in the URL Box '''About:Config''' and go there. Set the following Values:<Br> <Center> '''browser.newtabpage.enabled; false'''<Br><Br> '''browser.newtabpage.enhanced; false'''<Br><Br> '''browser.sessionstore.restore_pinned_tabs_on_demand; true''' </Center><Br> This will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.<Br><Br> If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. My max is set for 25:<Br><Br> <Center>'''browser.sessionstore.max_windows_undo; 25'''</Center><Br> Additionally, you could try this also. Have FF reset how much Disk Cache it will use for your system by changing the following to '''true''':<Br> '''browser.cache.disk.smart_size.first_run''' - false<Br> It will change back to '''false''' after FF is Exited and runs next time, setting-up your Disk Cache value. Maybe this doesn't need to run again, but I did it a while back and it 'appeared' to help me. <Br><Br> Finally, I did the following FireFox adjustments for my old 2010 computer with the '''Performance''' settings in '''Options''' as shown in the image attachment: <Br><Br> ~Pj

Изменено Pj