Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox goes to previous web page when scrolling up. How do I stop this?

  • 13 ответов
  • 1 имеет эту проблему
  • 20 просмотров
  • Последний ответ от Shadow110

more options

When I am viewing a web page on a tab where I have a browsing history (I went to the current page from another page) and I scroll up, it will sometimes jump back to the previous web page. How do I stop this action from happening? I have already tried a few solutions that were suggested on the support site but so far, none have stopped this action. I would only want to go back to a previous page when I click the "back" button... not when scrolling.

Все ответы (13)

more options

Hi ddenby! How are you scrolling up? Are you using a mouse with a physical scroll wheel, the arrow keys, or something else? Thanks!

more options

I am using the mouse wheel when it happens. Is isn't predictable though.. Sometimes it happens and sometimes it doesn't.. (usually when I accidentally attempt to scroll beyond the upper bound of the page/tab. e.g. quickly scroll to the top). but again, not always.

more options

Your mouse wheel might have a feature where you can click it to the side to go back in your web browser.

Try this for me; go to a webpage where you could go back (i.e. you've clicked a link in that tab so you have a history). Then, instead of rolling the mouse wheel up or down like usual, try pushing the whole wheel to the left. Does it feel like the mouse wheel "clicks" in that direction, and does your browser go back?

more options

The mouse wheel sits pretty low on the mouse but I can get it to click if I press hard enough to the left or right, but no, it doesn't cause the browser to go to the previous page.

more options

Hmm okay. Is it possible you're pressing down on the Alt key accidentally when you scroll? Alt + Scroll Wheel is a default shortcut for forward/back.

more options

no, just the mouse.. Thanks for trying to help.

more options

No problem! Unfortunately, I'm not sure what's going on here. My hunch is that this isn't a feature or bug of Firefox itself, but that something about your mouse or keyboard is accidentally triggering the Back action.

I'm afraid I'm not going to be able to be of much more help here. :( I hope you figure out what the problem is!

more options

again, thanks for trying.

more options

You might be holding down the Alt key while rotating the mouse wheel. There are specific actions defined to set what happens if you rotate the mouse wheel and hold down modifier keys like Alt or Ctrl or Shift.

  • mousewheel.with_*.action
  • mousewheel.with_alt.action = 2

You can disable an action by setting the related pref on the about:config page to 0 (zero).

0 means "Do nothing" 1 means "Scroll contents" 2 means "Go back or forward in the history" 3 means "Zoom in or out the contents"

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Thank you, but that was not the case... (see questions and answers to TimeSync1 above)

more options

@ddenby they are trying to help with different setups here. I think they already read through the posting. How old is that mouse and when was the last time you cleaned it? What kinda mouse it it? It sounds more like a mouse hardware failure more than a Browser.

Изменено WestEnd

more options

The mouse is fairly new. (only 4 or 5 mos/ use.. and.. I have cleaned it (bottom) a few times. I don't thinkit's the mouse. This hasn't happened with other browsers (Chrome, IE). If there isn't a software (FireFox bug) that's causing it then it would happen elsewhere.

I appreciate everyone's attempts to help with this but unless someone has some insight into FF's underlying code and/or control mechanisms, it is probably a dead issue.

Again thanks to all who have tried to help.

more options

Separate Security Issue, please update your Flash 28.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

You can try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.