Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

A website turns off my scrollbars. How can I prevent this, OR easily turn them back on?

  • 7 ответов
  • 1 имеет эту проблему
  • 282 просмотра
  • Последний ответ от FredMcD

more options

Often, some link will throw a popup and suddenly my horizontal and vertical scrollbars are gone. I have to go into about:config and turn dom.disable_window_open_feature.scrollbars to false, then restart Firefox.

Is there a way to prevent the scrollbars from being changed.

OR

Is there an easier way to turn them back on? A link? An easy script. It's a pain right now that this happens.

Thanks

Выбранное решение

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Прочитайте этот ответ в контексте 👍 0

Все ответы (7)

more options

See if this helps;

http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Enter dom.disable_window From this list, set everything to True.

The Dom.disable_window settings takes away the websites ability to set up new windows in a way that takes away user controls. http://kb.mozillazine.org/Dom.disable_window_open_feature.status

more options

I did exactly as you said and it still happened. Everything listed under dom.disable_window is still set to true, but my scroll bars still disappear.

Any other ideas?

more options

Hello grstorga,

Would you please take a look at jscher2000's post (Chosen Solution) in this thread :

https://support.mozilla.org/en-US/questions/1132323

Would that work for you  ?

more options

Thank you all for your replies, but I just went with an addon. It seems like there should be a way to lock scripts from disabling scrollbars, but all I can do is turn them back on.

Have a great weekend.

more options

grstorga said

Thank you all for your replies, but I just went with an addon.

Would you be so kind as to share the name of that add-on with us  ? Might be helpful to others with the same problem  !

Thank you in advance (and have a great weekend)  !

more options

McCoy said

grstorga said
Thank you all for your replies, but I just went with an addon.

Would you be so kind as to share the name of that add-on with us  ? Might be helpful to others with the same problem  !

Thank you in advance (and have a great weekend)  !


I'm so sorry - I should have mentioned it. I went with Scroll Everywhere by Unai Valle. It appears to work fine.

Thanks again!

more options

Выбранное решение

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.