Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

How to correct: Connection is not secure message on HTTPS site

  • 26 ответов
  • 2 имеют эту проблему
  • 7440 просмотров
  • Последний ответ от jscher2000

more options

Nothing on help pages explains how to fix the problem with the orange triangle on the lock on an HTTPS site. How can I secure the connection???

Выбранное решение

You can force connection to HTTPS for some things that cause the issue. I forgot when looked at the page I had HTTPS EVERYWHERE running : https://addons.mozilla.org/en-US/firefox/addon/https-everywhere/ The above will force a connection to say google analytics if has been coded with http, or to google fonts or....It can only force a connection if there is a connection to force it to ei a HTTPS address.

Прочитайте этот ответ в контексте 👍 0

Все ответы (20)

more options

Hi, what URL is this if mind sharing ? Are you getting a pop-up warning or just the icon ? Is page giving a warning or just the icon ?

Some sites will never get a full padlock as they have mixed HTTPS and HTTP pages. Some just encrypt pages where info is exchanged. Some sites have enabled their certificate wrongly and should be notified.

more options

Hi, as to Support and the duplicate question.

The duplicate has been sorta merged with this one but will not see content.

As to Support well it is done by Firefox Volunteers who take time out of their day/night to help other users with their issues. So no at times there is not anyone around as we are all over the world.

more options

I am seeing an orange triangle on the usually green lock on an HTTPS page. When I click on it, there is a message that the "Connection is not Secure." No change of settings will correct the issue. A suggestion that Shockwave Flash is responsible offers no other solution. Disabling the Flash plug-in does not correct the issue. Resetting browser defaults does not correct the issue. Asking, searching, posting questions... still Mozilla/Firefox has no answer to how one can re-secure the page.

Изменено Rafael Lecuona

more options
more options

Cannot paste image to this field.

more options

This is what I am seeing on a previously secure HTTPS site. How can I fix this problem?

more options

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

If nothing in the Help articles and you are running one of those Security Programs please see their Help Forum or update the program. Kaspersky had issues last night that was crashing Firefox.

more options

Forgot to mention, I have no problem with the URL you sent.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

  • Remove Cookies

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Изменено Shadow110

more options

While the connection is not 100% secure, you can see from the further description that the problem is with images in the page.

I'm not sure what you see (because I don't have a login), but perhaps there is some user-generated content like a message or forum post with an image linked from a different website. When Firefox encounters an image link using HTTP in a page that uses HTTPS, it retrieves the image because it's low risk, but it flags the lock with the warning triangle.

See also:

more options

I don't understand. A warning similar to this is what I see (Image attached). I read that it's about images but that doesn't help me solve the problem. How can I correct this issue?

more options

Cache and cookies have been cleared multiple times. Even uninstalled and reinstalled Firefox and problem persists. It also happens on Google Chrome. I've read all the info about the warning but none contain a solution.

more options

How would you prefer to solve the problem?

(A) Block insecure images in secure pages. You will not see the images and you will keep the green lock.

(B) Contact the website and have them fix the problem.

(C) Live with the current situation.

more options

I have blocked images but warning persists - green lock does not appear. Have contacted the website - They claim there is no problem. I am living with the situation but it's unacceptable as this site is supposed to be secure for legal reasons. I cannot find a solution.

more options

Page has green lock prior to log-in. Once signed in as myself is when the orange triangle warning appears. All proposed solutions have been attempted except the deeply complex settings, no home user should attempt. How can I revert to when this was not occurring?

more options

Выбранное решение

You can force connection to HTTPS for some things that cause the issue. I forgot when looked at the page I had HTTPS EVERYWHERE running : https://addons.mozilla.org/en-US/firefox/addon/https-everywhere/ The above will force a connection to say google analytics if has been coded with http, or to google fonts or....It can only force a connection if there is a connection to force it to ei a HTTPS address.

more options

You can check the Web Console for more detail about what mixed content is present on the page.

more options

rafaellecuona said

I have blocked images but warning persists - green lock does not appear.

How did you block images?

Have contacted the website - They claim there is no problem.

The site claims there is no mixed content in the page? Let's see whether we can track it down using Firefox's Web Console. You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

Then reload the page in the upper part of the tab using either of the following (to bypass cached files):

  • Ctrl+Shift+r
  • Shift+click the reload button

A bunch of messages should appear in the console. Above the list is a bar with the wording "Filter output". If you click that placeholder text and type mix then the list of messages should be limited to mixed content warnings. Are images listed? If so, do they seem to come from a logical source or could there be alien content in the page?

more options

I blocked images by selecting "block" option in Load Images in the permissions. Site does not claim to not have mixed content but that they cannot reproduce the issue so have no solution.

You lost me on the web console instructions. I got so far as to get this message below which means nothing to me:

unreachable code after return statement[Learn More] js:69:1217 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://location.services.mozilla.com/v1/country?key=fa6d7fc9-e091-4be1-b6c1-5ada5815ae9d. (Reason: missing token ‘x-csrftoken’ in CORS header ‘Access-Control-Allow-Headers’ from CORS preflight channel). Error: Error retrieving geoip data

Изменено Rafael Lecuona

more options

Whoops, you need to open the web console in the tab with the site that is giving you the problem, reload the page so the console can gather fresh data, and then check for any mixed content messages.

more options

cor-el said

You can check the Web Console for more detail about what mixed content is present on the page.

I wouldn't know what to do with more detail about what mixed content is on the page. I'd just like to correct whatever has changed since the last time this page loaded without this warning but I'm not getting anywhere.

  1. 1
  2. 2