Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox extremely slow to load web pages, Explorer works fine.

  • 10 ответов
  • 1 имеет эту проблему
  • 19 просмотров
  • Последний ответ от FredMcD

more options

Hi all, I'm using a MSI GF62-7RD laptop running Windows 10 64-bit, latest Firefox version (59.0.2 64-bit). For the last few weeks Firefox on my laptop has been taking years to load almost all web pages, while Internet Explorer on those same occasions was able to load the same pages in good time. The annoying thing is that Firefox on my desktop (Windows 7) is not similarly afflicted. And to make matters even stranger, my laptop when using other internet connections (at friends' houses etc.) is able to use Firefox without the speed issues I get at home.

This problem was also present intermittently on my last laptop (also MSI with the same OS), but now it seems to be a permanent state of affairs. I have variously in the past tried disabling accessibility services, refreshing Firefox, and doing a complete re-install (including deleting all Mozilla folders in the user's Appdata folder). Nothing seems to help....

All Replies (10)

more options

REFRESH INSTRUCTIONS Hi, please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Hi all,

Thanks for the suggestions, I tried doing a Refresh and deleting the profile, neither of those had any effect...

Running Firefox in Safe Mode didn't seem to help either... Makes me wonder whether it might therefore be a conflict of some kind between Firefox and Windows (or some element of the system) rather than a problem with Firefox itself?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia


If there is still a problem,

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

more options

Unfortunately as I'm entirely reliant on wireless internet at home (just an individual dongle, no router involved), restarting Windows in Safe Mode with networking was no use as it only allows ethernet connections as far as I can tell. Do correct me if I'm wrong about that...

I tried installing the 32-bit version, which I'll leave installed for now. It didn't make any difference, even after I did a refresh / profile delete / tried Firefox in Safe Mode again with the 32-bit version.

Pretty baffling stuff. The cynic in me wants to believe that it's a Microsoft conspiracy XD

more options

Did you ever check the Connection settings in Firefox? Firefox uses system proxy settings or auto-detected settings by default (as opposed to some other browsers) that could be set up faulty or perform worse. Try No proxy to see if that helps, and have a look at the general Internet / LAN settings used by Windows / Internet Explorer to see what they are - speed results should then be similar.

The fact you mentioned no speed issue at a friend’s place is also interesting, so there could be some network parameter not optimized for one of your network components. Such issues may not turn up when switching connections. Did you ever use some tuning tool to speed things up, such as MTU? (I recall doing so for a dial-up connection years ago, resulting in a pretty slow broadband connection as soon as that became available.)

You could also try to reset your network adapters. This Microsoft support article may be of help. And don’t forget to reset your modem / router, perhaps as a first step.

more options

No, never used a tune-up tool before. But I followed your suggestion re Firefox's proxy settings and wonder of wonders, it may have actually worked! I'll hold off on marking the problem as 'solved' for now, just because in the past the problem has gone away briefly only to return again. I did in fact try manually setting to no proxy with the 64-bit version and it didn't work, so it might be that this fix in combination with going back to a 32-bit version might have done the trick...

I shall wait a few days and report back, fingers crossed we've cracked it at last!

more options

Keep us posted.

more options

Well after a week or so of watching and waiting, the news is mixed. The problem kept happening on and off, although I did try some miscellaneous other things not directly related to Firefox. I tried starting windows with all non-Microsoft services disabled ('clean boot'), but that didn't do anything. So I can rule out background processess and such things. No antivirus other than Windows Defender (for which I've added exceptions anyway) so not that either it seems.

I did some internet speed tests over a few days, and discovered that while Explorer / Edge was more usable than Firefox, it too was MASSIVELY slow compared to what it should be. Download speed in Edge was 300Kbps or less, but on those same occasions if I downloaded a game in Steam it would be 10Mbps or more.

So in conclusion it seems that there are some system-wide bizarre things going on with browsers on my laptop, which is nothing I need to bother you fine people with. Thanks for all the suggestions!

P.S. Not sure whether to mark this as solved....technically it isn't, but the thread is likely 'finished'.

more options

Just leave it open. Maybe someone will know what's going on.