Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

FF + CSS is double-spacing as default.

  • 6 ответов
  • 1 имеет эту проблему
  • 8 просмотров
  • Последний ответ от acrizona

more options

This Mozilla support forum DOES NOT have this problem. Please notice I have pressed [Enter] at the end if each line. This is the third line. There are no blank lines. The following is copied from another un-related forum about "double spacing".


Before I describe this problem, let me describe my configuration. I am running Linux MINT on an Apple iMac. There is no Apple software on this machine. Firefox Quantum is my browser of choice. [Enter]

This is a new line. I now see three lines above, auto-word-wrap after 'Apple', and no extra blank lines. [Enter]

Now I preview my typing, and there are extra blank lines added after each. [Enter]

Have not seen this CR-LF problem since using DOS & WordPerfect (circa 1985).

CarriageReturn & LineFeed.

This is my 7th line of text. Count 'em. Depending on the width of this window, you may have more or less lines due to the auto-word-wrap feature. You counted the first blank line? CSS defaults to the Top Margin + Font Height = first blank line.


end of copied text.

Also, Mozilla Thunderbird defaults to this oddity, meaning all eMails I sent, were received double-spaced. However, it has File, Edit/Preferences/Composition/HTML, checkbox labeled: 'Use Paragraph format instead of Body Text by default.' I switched the X to space, turning double-line-spacing OFF.

My question: How do we turn this oddity OFF in Firefox ?

Все ответы (6)

more options

See what I mean ??? What I typed, is NOT what you see.

Изменено acrizona

more options

Hello, please always :

You can try this : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Move to this if the issue is still there : The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Thunderbird's HTML editor is a "rich text" editor, unlike the simple text entry forms on this site.

Generally speaking a rich text editor interprets:

  • Enter or Return => new HTML paragraph (<p>), which will have a blank top and bottom margin by default
  • Shift+Enter or Shift+Return => line break (<br>)

In Thunderbird, there is a Preference you can change here to change the Enter/Return key to creating line breaks:

Thunderbird > Preferences > Composition > General, HTML

uncheck "Use Paragraph format instead of Body Text by default"

Firefox doesn't have anything like that as far as I know.

more options

Thanks - that was exactly my question...(enter key) How do we turn this oddity OFF in Firefox ?(enter) AND... This Mozilla support forum DOES NOT have this problem.(enter) I am in SafeMode - U see only single-spaced lines.(enter) SafeMode now OFF - U see only 5 single-spaced lines.

more options

When you are using a simple form like the ones on this site, you are not creating HTML. Just text.

If you are using an HTML editor, you need to observe the rules of that editor as to what different keys do. I'm not aware of any way to universally override the way a site's editor interprets Enter and Shift+Enter. That's up to the website. If you don't like how their editor works, please let them know your feedback.

more options

I don't know much about CSS StyleSheets, but the crowd response is "its works fine in all other browsers". Google CSS discussions about this very problem, all entail spacing-relative-to-font-height. Sometime after 2012, the 'norm' ??? was changed to add 1-font-height-space before the paragraph, and 0.5-font-height-space after each line wrap-around. This default plus your Enter-key totals 2-font-spaces between paragraphs.

Simply stated, each time you hit Enter, you are ending a paragraph.

However, unless you specify the spacing in your CSS coding, different browsers do not default the same.

As mentioned before, "this forum does not have this problem". All I know is; Thunderbird has an answer to this problem.