Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Most sites not displaying as a mobile site when system display size is set to "Small"

  • 3 ответа
  • 2 имеют эту проблему
  • 1870 просмотров
  • Последний ответ от cozmicon

more options

In 59.0.2 on Android, the majority of websites display as the desktop version when the display size in Android is set to "Small".

For example, the LinkedIn website renders as the full desktop site (even with the "Request Desktop Site" checkbox is unchecked). As soon as I go into my system settings and change the display size back to "Default", Firefox renders the site correctly.

Is there any way to get this fixed? Seems like it's more of a bug than a user/site issue as it occurs on most websites.

As a note, this display setting is available on my Pixel 2 XL with Android 8.1.0 under Settings > Display > Advanced > Display Size.

Выбранное решение

The primary way to fix that would be to use the default UI density. Which disables the tablet interface of Firefox and sets the user agent back to the mobile user agent.

If you don't want to do that you can open about:config and set "general.useragent.override" to "Mozilla/5.0 (Android; Mobile; rv:59.0) Gecko/59.0 Firefox/59.0".

Every few months as Firefox releases new versions you should increment the user agent, for example when Firefox 60 is released in about 3 weeks it should be updated to "Mozilla/5.0 (Android; Mobile; rv:60.0) Gecko/60.0 Firefox/60.0" .

Прочитайте этот ответ в контексте 👍 1

Все ответы (3)

more options

Выбранное решение

The primary way to fix that would be to use the default UI density. Which disables the tablet interface of Firefox and sets the user agent back to the mobile user agent.

If you don't want to do that you can open about:config and set "general.useragent.override" to "Mozilla/5.0 (Android; Mobile; rv:59.0) Gecko/59.0 Firefox/59.0".

Every few months as Firefox releases new versions you should increment the user agent, for example when Firefox 60 is released in about 3 weeks it should be updated to "Mozilla/5.0 (Android; Mobile; rv:60.0) Gecko/60.0 Firefox/60.0" .

more options

Perfect - setting the general.useragent.override resolved the issue.

Is there somewhere specific to make a feature request to just outright disable the tablet interface via a menu option? I don't mind updating the user agent every few months, but it would be nice to just have it as a stock setting that doesn't need to be updated.

Изменено sacody

more options

I have the same issue - just bought a nokia 7 plus

With Google Chrome, sites load in properly, it's only Mozilla which has this issue.

The above config change helps, but it ruins the "request desktop site" button, as it still goes to the mobile site after you tick it in, once you change configuration.

Ultimately, shouldnt it just pick up the screen size properly and then open the mobile page, if you're checking the pages from a mobile device?