Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Firefox 'save picture as' function chooses last directory

  • 16 ответов
  • 1 имеет эту проблему
  • 1424 просмотра
  • Последний ответ от BaraBrith

more options

I've seen this question asked before in various places but the 'approved' answers don't seem to answer my problem. I have a relatively small SSD for my C: drive. I want all my downloads to automatically go to a folder called D:\downloads on my secondary drive.

Please note the word ALL. If I save an occasional picture to my desktop I don't then want every subsequent picture to go to my desktop. I want the next save to revert back to my default location.

I don't see why this is so difficult. I just want everything to go into the same folder unless I specifically tell it otherwise.

I have read answers which say:- You can disable the feature to remember a host based download directory by creating a new Boolean pref on the about:config page with the name browser.download.lastDir.savePerSite pref and set its value to false.

But if my files are from different sites that doesn't seem to help. I just want every single download to go into the same folder, regardless of host, extension, mime types, what it had for breakfast etc etc.

Выбранное решение

@BaraBrith Well, it seems you've done it then in your own way, congrats. Now, please, mark the problem as solved if you'd like. :)

Прочитайте этот ответ в контексте 👍 0

Все ответы (16)

more options

Try this and if you have already tried it just let me know.

more options

I've tried that before. Just to double check I changed it to a completely new folder on D:

Did a Google for images of dogs. Saved first one - FF suggested Desktop - saved it there. Saved second one -FF suggested Desktop -changed to Downloads on C: Saved third one -FF suggested Downloads on C:

It seems addicted to last saved folder.

more options

Reset everything then try again - https://goo.gl/9iH8U1

more options

Sajjad Bin Samad said

Reset everything then try again - https://goo.gl/9iH8U1

Did that no change.

more options

Try this last solution - someone in the community suggested that it works

If you set Firefox to ask you where to save, it stores your last download folder on a site-by-site basis. To make it remember the same last folder regardless of site, you can do this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste lastdir and pause while the list is filtered

(3) Select and copy the following preference name:

browser.download.lastDir.savePerSite (4) Right-click a blank area of about:config and choose New > Boolean

(5) Paste the preference name (right-click > Paste or Ctrl+v) then click OK

(6) Accept the default value of false and click OK. The new preference should appear in about:config.

(7) If the browser.download.lastDir preference contains a folder you do not want to use for the next save, clear it by using right-click > Reset, or edit it to your liking.

I think most likely these changes will take effect on your next save.

more options

Thanks for taking the time to construct that detailed answer but I did mention in my original post that it didn't work for me.

I've experimented with Chrome and Edge and they both do exactly the same. I'm beginning to wonder if it's a Win 10 setting.

more options

I would think not as has not effected me or on systems I have worked on. Though anything is possible.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

I don't know what to tell but I have never faced a problem like this cause I already use a download manager. As you said if it's a win10 setting malfunction, I think it's possible because, from my experience using win10 it always goes back to its default setting no matter what you do.

Try to change the Download folder target from your user folder in windows.

more options

Pkshadow said

I would think not as has not effected me or on systems I have worked on. Though anything is possible. uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.


Did all that. No files in C:\ProgramData so searched folder and deleted everything that came up in the subfolders. Then run CCleaner on files and registry. Restarted machine again. Installed a fresh FF. Did not reload any extensions or profile settings.

Searched for horses - images in Google. Horse 1 - open image in new tab -save image as -opened Downloads folder - saved image - closed tab. Horse 2 -opened in new tab- save image as - opens Downloads folder - change folder to Desktop and save -close tab. Horse 3 - open image in new tab - save image as - FF opens Desktop folder.

So there's no difference - it continually saves to last used folder instead of the specified, default download folder.

EDIT: Went into about:config and entered the boolean browser.download.lastDir.savePerSite and set as false - that didn't work either.

Изменено BaraBrith

more options

Hi Guys I've been doing some research. On the FF site for browser.download.lastDir.savePerSite it says

If you set it to false

   The last used directory for any download (stored in browser.download.lastDir) will be the preselected directory in the file picker.

That's exactly what I DON'T want it to do.

more options

BaraBrith said

Hi Guys I've been doing some research. On the FF site for browser.download.lastDir.savePerSite it says If you set it to false The last used directory for any download (stored in browser.download.lastDir) will be the preselected directory in the file picker. That's exactly what I DON'T want it to do.

So set it to true.

more options

Hi Guys, Me again.

I've found a workaround. There's an add-on which works with Quantum called Save In

It adds a link to the right click menu and if you click the . (i.e. the dot) at the top of the list it saves to your default folder.

You can then put a named Symbolic Link into your Downloads folder. You add that name to the Save in Options section list.

It will then save to your preferred folder. Which for me was on my secondary drive. So you can choose one or the other.

I would guess you could add more than one sys-link, each one with a different name - to direct yourdownloads to a variety of folders. Although I haven't tried this yet. (it's late)


If anybody's interested the add-on is here: save-in

If you can't make your own sys-links there some software to do that here:

Sys-Link-Creator

Изменено BaraBrith

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Make backups of bookmarks and Profile. Do know that the Profile is where the saved settings are.

  • Repair System Registry and Files

Find the Dos Prompt Right or Powershell Click and Run as Administrator then : Copy/Paste to Dos Window : DISM /Online /Cleanup-Image /RestoreHealth then hit Enter. Reboot when completed. Note : DISM goes up to Microsoft for new ones.

more options

Выбранное решение

@BaraBrith Well, it seems you've done it then in your own way, congrats. Now, please, mark the problem as solved if you'd like. :)

more options

Pkshadow said

BaraBrith said
Hi Guys I've been doing some research. On the FF site for browser.download.lastDir.savePerSite it says If you set it to false The last used directory for any download (stored in browser.download.lastDir) will be the preselected directory in the file picker. That's exactly what I DON'T want it to do.

So set it to true.

I don't think setting it to true isn't going to work either because that will save it on a per host basis. I'm talking about saving all pictures - no matter what host - to the same folder; and I always want it to stick to that folder even if I decide a single pic goes elsewhere. If I save a single pic from a host to the desktop it'll probably just assume that's my new folder for that host and the next etc and I'm back to square one.

more options

Hi guys, It was late last night when I eventually got myself sorted so I didn't really thank everybody for all their comments and efforts to help.

So thank you all for taking the time and effort to post. At the end of the day I found a workaround but your comments helped me eliminate a lot of possibilities and gave me a better understanding of what I was trying to achieve.

I didn't use the restore health to Windows suggestion because I'd found my workaround by then, but hopefully it will be of benefit to somebody else who comes across this thread.

I'm quite pleased with my little workaround, it does all I need, and it has the added bonus that if you save two files with the same name then it auto-renames the second without the dialogue box popping up.

So thank you all once again and have a nice weekend.