Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

html file click expect new tab, but gives "Firefox already running, but is not responding"

  • 4 ответа
  • 1 имеет эту проблему
  • 275 просмотров
  • Последний ответ от Ole_Knudsen

more options

The "Firefox is already running, but is not responding" is really hostile and unhelpful. I don't want to mess with multiple Firefox profiles. I want to record the local file in the active Firefox history.

Just add the local file in new tab on the Firefox that is already active. Should work like click a bookmark in firefox, so why not treat this the same way? Needless to say, that this is what Chrome does.

Would be okay if Firefox pops up a prompt like "do you want to open the local file in a new tab or window?"

Выбранное решение

Just add the local file in new tab on the Firefox that is already active

Does the same thing happen when no Firefox copy is running, and if not, what Firefox instance is opened?

Make sure you don’t have multiple installations of Firefox on Linux, such as one by your distro and one installed manually. If that’s the case and you would like to keep it that way, only one of them should be set as default browser for all definable actions, which could extend to a PDF helper application, if any.

Chances are the second Firefox instance/version is simply trying to use the same (or even only) profile, obviously occupied/locked for that reason. The same can happen when e.g. a release and Dev Edition is installed.

Прочитайте этот ответ в контексте 👍 0

All Replies (4)

more options

This happens if you try to open a link in the default browser with a double-click and Firefox was started with the -no-remote command line switch. In such a case you would have to drag the link to a Firefox window. Otherwise you need to refrain from using -no-remote.

more options

I just start Firefox and keep it running with many windows and tabs. I am not aware, that I specify -no-remote anywhere. Is this some defauit, that can be turned off? Is there some security risk turning it off?

I should probably add, that the real problem is http links embedded in PDF files and other documents, where the viewer just starts whatever web browser I have as system default. I am running Red Hat Linux.

Am trying to change the default Web browser from Firefox to Chrome because of this. Firefox will still be my preferred web browser, but just not when it comes to clicking links in other applications than Firefox itself.

Изменено Ole_Knudsen

more options

Выбранное решение

Just add the local file in new tab on the Firefox that is already active

Does the same thing happen when no Firefox copy is running, and if not, what Firefox instance is opened?

Make sure you don’t have multiple installations of Firefox on Linux, such as one by your distro and one installed manually. If that’s the case and you would like to keep it that way, only one of them should be set as default browser for all definable actions, which could extend to a PDF helper application, if any.

Chances are the second Firefox instance/version is simply trying to use the same (or even only) profile, obviously occupied/locked for that reason. The same can happen when e.g. a release and Dev Edition is installed.

more options

I was running Firefox 58 Quantum , but Linux system default web browser was still Firefox 52 ESR.

Thank you very much for the hint about multiple versions.