Search Support

Update to 52.5.2 (64-bit) RUINED my settings (addons don't work) How do I Revert to 52.1.1.1

  • 41 ответ
  • 2 имеют эту проблему
  • 174 просмотра
  • Последний ответ от Zenos

more options

There really needs to be a "revert to my previous version" button. This sucks; I'm going to have to do a lot of work to get it working again.

I cannot read the INBOX index because the font in the application windows is miniscule. A capital letter is 2mm high on my 17" screen. No human being can read lettering this small !!!

The addon list under Extensions does not indicate that any have been disabled. I think that I need "No Small Text" and "Theme Font & Size Changer" to become operational.

OR it might be that long ago I changed something in about:config but I'm not a programmer; I don't remember this stuff.

How do I revert to 52.1.1.1 (64 bit, I think) ???

All Replies (20)

more options
more options

The Theme Font & Size Changer add-on stopped working on 5th Jan.

You can download a fixed version here:

http://www.rossde.com/ThemeFontSizeChangerNoexpire/index.html

more options
more options

Reverted to 52.1.1 but problem still exists. The 52.5.2 update must have trashed some settings.

Can't run the .mar file. How do I install the update?

more options

The addon Zoom Button for Thunderbird still works, but that only operates on the email viewing -- the problem is that the application windows fonts are miniscule.

more options

Is it possible that doing the Tbird update did something to break Theme & Font Size Changer? The control button is missing from the toolbar, but it is not listed as Disabled.

I see on its page this UNDATED message: Theme Font & Size Changer 56.0 THUNDERBIRD USERS PLEASE SWITCH TO THE NEW THUNDERBIRD VERSION BY BELOW URL: https://addons.mozilla.org/en-US/firefox/addon/theme-font-size-changer-for-tb/

HOWEVER WHEN I GO TO THAT PAGE: Theme Font & Size Changer for TB by Baris Derin snip This add-on is not available on your platform.

I'm using El Capitan 10.11.6

more options

Contact the add on author. Zenos told you Theme and Font add on was broke in his first post and gave you a link to a fixed version.

more options

I am also confused by the fact that some addons seem to exist in both Firefox and Thunderbird. I would presume that since these are completely separate programs, that all the addons would need to be independantly installed in the respective application. And that there would be no "leakage" of between applications.

Theme & Font Size Changer is operating for me in Firefox. So I hesitate to try to download a different version -- cannot risk having it break in Firefox as well.

Happy new year... (editted for language)

Изменено Wayne Mery

more options

Some extension authors make their extensions for two or more things they use like say desktop Firefox, Thunderbird, SeaMonkey and Android Firefox for example.

The extensions do need to be installed separately in each application as one cannot install a extension in desktop Firefox and expect it to be installed in Thunderbird instead or also.

The vast majority of extensions being hosted at addons.mozilla.org are made by a third-party author or company. Most of the Mozilla made extensions are by this account https://addons.mozilla.org/firefox/user/mozilla/

edit: 52.5.0 was the previous version and not 52.1.1 as you can see at https://www.mozilla.org/en-US/thunderbird/releases/

Изменено James

more options

Airmail said

Contact the add on author. Zenos told you Theme and Font add on was broke in his first post and gave you a link to a fixed version.

Reverted to 52.1.1 but problem still exists.

more options

Zenos said

The Theme Font & Size Changer add-on stopped working on 5th Jan. You can download a fixed version here: http://www.rossde.com/ThemeFontSizeChangerNoexpire/index.html

oh, just noticed this. responses seem to be overlapping. will try. like to save copy existing version...

more options

"could not be installed because it appears to be corrupt"

more options

The existing version of Theme Font & Size Changer has a line of code that makes it stop after 5th Jan. You can install it and reinstall it until you're blue in the face, but so long as it's later than Jan 5th, this add-on won't run.

You either set your pc clock back to some time before 5th Jan, or install a fixed version of the addon.

more options

The other factor to bear in mind is that Firefox has changed the add-ons mechanism, with the result that old add-ons will no longer work and you are reliant on add-on authors rewriting their code to the new model.

Thunderbird has stayed with the original add-ons system. So authors of add-ons that can be used in both Thunderbird and Firefox now have the additional burden of maintaining two versions using different technologies.

There is absolutely no reason why updating an add-on in Firefox should affect the equivalent add-on in Thunderbird.

I've just switched to a new laptop with a considerably higher resolution screen. Having adjusted the dpi setting to match the screen, my fonts and so on are all at pretty much the same size as they were on the previous machine. I wonder how many complaints about tiny fonts are really caused by inappropriate dpi settings.

more options

I think there is a typo in that URL. Note that it says "Firefox" right in the middle?

At least two users have downloaded my fixed version and used it successfully. So I don't think it's broken. But it may not be compatible with older versions of Thunderbird.

more options

Figured out how to download the file, but how do I run it & get it to try to insert itself into TB? Its an .xpi file.

more options

Zenos said

The existing version of Theme Font & Size Changer has a line of code that makes it stop after 5th Jan. You can install it and reinstall it until you're blue in the face, but so long as it's later than Jan 5th, this add-on won't run. You either set your pc clock back to some time before 5th Jan, or install a fixed version of the addon.

I am referring to the "no expiration" version.

more options

Zenos said

I've just switched to a new laptop with a considerably higher resolution screen. Having adjusted the dpi setting to match the screen, my fonts and so on are all at pretty much the same size as they were on the previous machine. I wonder how many complaints about tiny fonts are really caused by inappropriate dpi settings.

My MacBookPro has a native resolution of 1920x1900. Any application should self-adjust. The user cannot be expected to fiddle with his DPI settings for each app. And why pay for a better DPI screen if you cannot utilize it?

Sounds like TB is still defaulting to a green-screen, 80 character per line CRT resolution.

And if you change to a different resolution, the window size can expand so that things you need to click on are offscreen. Then resetting the DPI involves major surgury, like restarting the machine in a special mode to return EVERYTHING to default states. So hours of fixing the whole machine. IF you know HOW to do it.

more options

James said

edit: 52.5.0 was the previous version and not 52.1.1 as you can see at https://www.mozilla.org/en-US/thunderbird/releases/

Huh? I said that I, myself, me, was using 52.1.1.1 prior to foolishly clicking on an upgrade notification yesterday, which installed 52.5.2. That broke it, so I figured out where to find 52.1.1 and re-installed it. Still broken.

THEN I tried to install the "no expiration" version of Theme & Font. But it fails, saying its corrupt.

I have downloaded the .xpi file for the No Expiration version. Its on my computer. So how do I run it to install it in a way that bypasses the web-based auto-installer which thinks its corrupt?

more options

Zenos said

I think there is a typo in that URL. Note that it says "Firefox" right in the middle? At least two users have downloaded my fixed version and used it successfully. So I don't think it's broken. But it may not be compatible with older versions of Thunderbird.

What URL? From this page: http://www.rossde.com/ThemeFontSizeChangerNoexpire/index.html

 I click on "get it here" which invokes the URL:

http://www.rossde.com/ThemeFontSizeChangerNoexpire/theme_font_size_changer-53.0+sm+tb_noexp.xpi

and click on "install now" and it tells me fails because its corrupt.

Is TB 52.1.1.1 too old ? I could try the 52.5.2 version instead.

Awakened at o-dark thirty -- just as I was getting to sleep -- because I had to clean up vomit & shit, didn't get back to sleep, spent all my precious free time trying to fix THIS effing situation...

  1. 1
  2. 2
  3. 3