Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

access ipv6 sites - firefox now prefers ipv4

  • 7 ответов
  • 4 имеют эту проблему
  • 3379 просмотров
  • Последний ответ от boab

more options

Since upgrade to 57.x firefox defaults to ipv4 and not ipv6 as before. sites ipv6-test.com and test-ipv6.com highlight this problem.

is there a way to try ipv6 first again please?

(I have "public" internet sites available ipv4 and ipv6, when i access them intenally via ipv6 all work well. but via ipv4 i have to go out to internet and back in again which my firewall does not like. Work arround is to use internal 192.168.x.x address but this is messy due to Https complications)

Since upgrade to 57.x firefox defaults to ipv4 and not ipv6 as before. sites ipv6-test.com and test-ipv6.com highlight this problem. is there a way to try ipv6 first again please? (I have "public" internet sites available ipv4 and ipv6, when i access them intenally via ipv6 all work well. but via ipv4 i have to go out to internet and back in again which my firewall does not like. Work arround is to use internal 192.168.x.x address but this is messy due to Https complications)

Выбранное решение

Problem was with my internal dns server (bind9) switched my windows 10 machine to use opendns and all works as intended.

No problem with Firefox. Many thanks for your assistane everyone, sorry for the false alarm.

Not sure when i switch over to my internal dns server, but at lease i can fault find and fix that.

Прочитайте этот ответ в контексте 👍 0

Все ответы (7)

more options

Hmm, when I visit the first test site in Firefox 57.0.4 on Windows 7 (x64), it says my browser defaults to IPv6. I don't know what explains the difference.

One thing you could try while you wait for any authoritative explanation is to try a fresh Firefox profile.

New Profile Test

This takes about 3 minutes, plus the time to test your sites.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Jan2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please skip over any requests to create accounts or approve extensions so they do not influence your test results.

Do your IPv6 tests work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

Thank you jscher2000, i have just tried your proceedure and it made no difference. Ipv6-test.com still reports default ipv4 no fallback (all else aok). I am also running 57.0.4 and windows 10 (both on automatic update). I have now learned a bit more about about firefox, only been using it for a couple of months, Thank you and a Happy New Year.

more options

I myself think those are internet protocals and only come into effect as Ivp6 was to increase IP access and if those sites don't have or Ivp6. I doubt you can do Ivp6 on those sites and it will default back to Ivp4 instead. That is how I see it.

more options

Your ISP dictates in the long run what you connect out as/to. You can change settings in your OS but again will be over ride by ISP.

This is not a Firefox issue.

Please let us know if this solved your issue or if need further assistance.

more options

I have no issues connecting to IPV6 only sites or to IPv4 sites. When sites are both I appear to prefer IPv4 and do not fallback to IPv6. Firefox used to prefer ipv6 and fallback to ipv4. My ISP for IPv4 and IPv6 are different. I will do some tracing on DNS responces etc to see if that helps.

more options

Выбранное решение

Problem was with my internal dns server (bind9) switched my windows 10 machine to use opendns and all works as intended.

No problem with Firefox. Many thanks for your assistane everyone, sorry for the false alarm.

Not sure when i switch over to my internal dns server, but at lease i can fault find and fix that.

more options

I have now tidied up my dns config files and all is now well.

Problem appeared to be "filter-aaaa-on-v4 yes;" which i inserted years ago and marked up as not working, somehow recent update or somthing made it active.

Thanks for pushing me beyond Firefox and helping resolve problem.