Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

"[add-on] could not be installed because Firefox cannot modify the needed file"

  • 1 ответ
  • 16 имеют эту проблему
  • 954 просмотра
  • Последний ответ от cor-el

more options

I have been trying to install add-ons such as Firebug, Enhancer for YouTube, and TinEye Reverse Image Search from https://addons.mozilla.org/en-US/firefox/extensions/ as well as from the Add-ons Manager. However, in the case of the Add-ons Manager, I get the message "an unexpected error occured during installation". When I try installing an add-on from the url mentioned above, I get the message "[add-on] could not be installed because Firefox cannot modify the needed file".

Unfortunately, I don't think this error message is included in the "Unable to install add-ons (extensions or themes)" page of the website. I took a look at the Profile folder under Application Basics in Troubleshooting Information and searched for files with the name "extensions". I followed the instructions for corrupt extension files and was only able to find and delete a file named "extensions.json". Upon restarting Firefox, I was still unable to install any add-ons and a new "extensions.json" was created.

Also, while on the add-on page (url mentioned above), I checked the Permission section of the Page Info and the radio button "Allow" for "Install Add-ons" was checked.

I have been trying to install add-ons such as Firebug, Enhancer for YouTube, and TinEye Reverse Image Search from https://addons.mozilla.org/en-US/firefox/extensions/ as well as from the Add-ons Manager. However, in the case of the Add-ons Manager, I get the message "an unexpected error occured during installation". When I try installing an add-on from the url mentioned above, I get the message "[add-on] could not be installed because Firefox cannot modify the needed file". Unfortunately, I don't think this error message is included in the "Unable to install add-ons (extensions or themes)" page of the website. I took a look at the Profile folder under Application Basics in Troubleshooting Information and searched for files with the name "extensions". I followed the instructions for corrupt extension files and was only able to find and delete a file named "extensions.json". Upon restarting Firefox, I was still unable to install any add-ons and a new "extensions.json" was created. Also, while on the add-on page (url mentioned above), I checked the Permission section of the Page Info and the radio button "Allow" for "Install Add-ons" was checked.

Изменено michaelc90

Выбранное решение

This means that Firefox needs to unpack the XPI file because the extension tries to modify some of its content and fails.

Try to install the extension in Firefox Safe Mode.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Прочитайте этот ответ в контексте 👍 3

Все ответы (1)

more options

Выбранное решение

This means that Firefox needs to unpack the XPI file because the extension tries to modify some of its content and fails.

Try to install the extension in Firefox Safe Mode.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.