Search Support

cannot scroll the menu on a restaurant website

  • 24 ответа
  • 5 имеют эту проблему
  • 155 просмотров
  • Последний ответ от Happy112

more options

the website for Corner Table, Minneapolis has a menu which Firefax cannot scroll though IE and Edge can scroll???

All Replies (20)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Can you attach a screenshot?

more options

A dialog say the image is too large to load here. I resricted the image by holding down alt when I pressed prt sc. nevetheless it is too large.

more options

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?
more options

Same problem in safe mode.

more options

Today uploading screenshots seems to be impossible (I've tried many. many times)

Point is : the menu shows a scroll bar in Edge, but there's no scrollbar in Firefox.

(scrolbar is at the right side of the menu in Edge )

See : https://www.cornertablerestaurant.com/menu/

Изменено Happy112

more options

Very odd;

(Norton) Dangerous Website Blocked You attempted to access: https://www.cornertablerestaurant.com/menu/ This is a known dangerous website.


I went to the site anyway. No scroll bar. But when I used the zoom controls, I got to see the rest of the menu. The smaller I made the print, the more I could see. But the print was smaller also.

I then tried Win IE. The menu displayed a scrollbar, but the menu only displayed 2 lines at a time.


You should contact the sites support and let them know of this.

more options

Thanks for the information,

more options

Thanks for the information.

more options

Naar said

Thanks for the information,

I've had absolutely no problems with that site - except for the missing scrollbar in Firefox. The scrollbar works just fine in Edge (for me, anyway).

This could be fixed by adding a line in the chrome/userChrome.css file in your profile, but a user shouldn't have to do that.

See : https://developer.mozilla.org/en-US/docs/Web/CSS/overflow-y

I'm hoping that somebody else will come up with the perfect solution.

Изменено Happy112

more options

You can reduce the size of the Firefox window and possibly use the Firefox Screenshot to take the screenshot.

You can click the Download button to save the screenshot to your hard drive (Save saves the image to internet).

more options

The scroll down arrow is only an arrow and doesn't have any JavaScript code attached (onclick attribute or 'ev' button attached) as would be expected.

<div class="scroll-down-bt">
	<a href="#"><img src="https://www.cornertablerestaurant.com/wp-content/themes/cornertable/images/scroll-arrows.svg" alt="Scroll Down"></a>	
</div>

The website has a CSS rule to hide the scroll bar in Mozilla browsers.

.site-content {
	overflow: -moz-scrollbars-none;
}

Add code to the userContent.css file.


@-moz-document domain(www.cornertablerestaurant.com){
 .site-content { overflow-y: visible !important; }
}

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userContent.css file in the editor window
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
more options

The 'fox' wouldn't let me upload this screenshot yesterday, but is in a better mood today - here's the scrollbar that shows in Edge, but is missing in Firefox:

more options

And here's the same page in Firefox - no scrollbar :

Изменено Happy112

more options

Here is a screenshot that shows the scroll bar with the CSS code I posted above in userContent.css

more options

Somebody marked one of my posts as 'Chosen Solution' - please remove that mark, as that post didn't 'solve' anything .........

more options

cor-el said

Here is a screenshot that shows the scroll bar with the CSS code I posted above in userContent.css

Like I said before : That's how it can be done, but (IMHO) users shouldn't have to do that. You can't expect users to add code in order to make things work - just isn't right.

more options

Happy 112 No I don't think I did indicate any chosen solution. My solution at the onset was simply to use Edge or IE. I posted the question because I thought that Firefox was at fault. The Fox, though I like it for its security choices, has many quirks that require adjustment when navigating websites. I often click the box that asks if some info was helpful.I do so because the info is interesting and new to me. However, it has rarely been helpful in solving the problem. I remain ,even after using the forum several times, confused about the way it works and very little interested in some responses. I am an intelligent user of the web in a limited way but not a computer techy. The forum seems less a place to get direct help than a place to become more computer savvy . I appreciated greatly the remark by you that users should not have to use code to get things right. I am never going to make changes to my registry or mess around with the worikings o my computer. It's enough that after every other update by HP or Microsoft I have to spend an hour or so to put things back to what they were before the update.

I did appreciate the fact that you took the trouble to tell the source  of the issue to do something about it. Good wishes and have a happy but spooky Halloween.  Dudley
more options

Would you please be so kind as to remove the 'Chosen Solution' mark from my post  ?

You can do so by clicking on the Undo button to the right of that post.

Thank you in advance  !

more options

Noe that is is the website that uses CSS code to disable the scroll bar that only has effect in Firefox as you can see by the -moz prefix.

.site-content {
	overflow: -moz-scrollbars-none;
}

The code I posted above override this rule and makes the hidden the scroll bar visible.

The scroll button(s) that they added instead aren't working for some reason.

You can contact the website and ask them to look into this.

Изменено cor-el

  1. 1
  2. 2