Search Support

error msg 55.03 not comp w/min>55.02, max<55.02?

  • 1 ответ
  • 5 имеют эту проблему
  • 1145 просмотров
  • Последний ответ от cor-el

more options

Been a Firefox user for yrs, this afternoon, auto update runs while trying to open browser and then a get an error box popping up titled XULRunner. Msg states Error: Platform version '55.0.03' is not compatible with minVersio>=55.0.2 maxVersion<=55.02. I have no idea what that means or how to fix it so I can go back to using Firefox and getting access to my bookmarks. Pls help. Thanks-Aaron

Выбранное решение

An error message about XPCOM missing or about platform version usually happens because of a failed Firefox update that left you with a mixture of old and updated files in the Firefox program folder. This can happen in case security software was keeping a handle of some of the files in the Firefox program folder preventing Firefox from replacing all the files. You can do a clean reinstall to ensure that all files are replaced. You may have to disable security software temporarily in case the problem persists.


Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • do NOT remove "personal data" when you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (64 bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32 bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.


Прочитайте этот ответ в контексте 👍 1

All Replies (1)

more options

Выбранное решение

An error message about XPCOM missing or about platform version usually happens because of a failed Firefox update that left you with a mixture of old and updated files in the Firefox program folder. This can happen in case security software was keeping a handle of some of the files in the Firefox program folder preventing Firefox from replacing all the files. You can do a clean reinstall to ensure that all files are replaced. You may have to disable security software temporarily in case the problem persists.


Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • do NOT remove "personal data" when you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (64 bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32 bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.