Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I want to stop the banner that asks me: Do you want to receive notifications from this site?

  • 8 ответов
  • 6 имеют эту проблему
  • 84 просмотра
  • Последний ответ от SoundFlyer

more options

Whenever I search and get a new webpage with notifications I get an extremely irritating banner from Firefox: Do you want to receive notifications from this site? I have to dismiss this by clicking the little x in the top right

I don't want notifications from any site and most of all I don't want Firefox to keep asking. So how do I stop this banner popping up?

Sf


Update

SoundFlyer said

ps... Happy112 - just checked on my Windows 10 tablet and it is exactly as you say, under options, etc., but there is no 'options' in IOS and no 'dnd'.

Изменено John99

All Replies (8)

more options

Hi   !
There are two ways to stop these notifications:

  • 3-bar menu > Options > Content > Notifications > and check the 'do not disturb' box.
  • In the upper left corner (on the address bar) there is a little circle with the letter 'i' in it; click on it ; click on 'More Information'; then on 'Permissions' and scroll down to 'Receive Notifications', and select the permission you prefer.
more options

Happy112 said

Hi   !
There are two ways to stop these notifications:
  • 3-bar menu > Options > Content > Notifications > and check the 'do not disturb' box.
  • In the upper left corner (on the address bar) there is a little circle with the letter 'i' in it; click on it ; click on 'More Information'; then on 'Permissions' and scroll down to 'Receive Notifications', and select the permission you prefer.

Thanks for the response but on the 3bar menu I don't get to a 'don't disturb' box only DRM and POP-UPS tick boxes, and on the 'i' menu I only get to stop notifications for a particular site. This leaves me unable to stop the actual pop up banner that asks the question. I do get to an article about 'web push' and suspect I have to turn the whole thing off.

more options

SoundFlyer said

Thanks for the response but on the 3bar menu I don't get to a 'don't disturb' box only DRM and POP-UPS tick boxes.

One more time: 3-bar menu > Options > Content > Notifications (which is under DRM) and check the 'do not disturb' box.   It   is   there,   really   !

more options

Happy112 said

SoundFlyer said
Thanks for the response but on the 3bar menu I don't get to a 'don't disturb' box only DRM and POP-UPS tick boxes.

One more time: 3-bar menu > Options > Content > Notifications (which is under DRM) and check the 'do not disturb' box.   It   is   there,   really   !

...fraid not... but I have just searched for 'do not disturb' facility on Firefox and get info about an 'add-on' that makes switching it on/off easier in the Windows version. But, apparently, the 'dnd' function is not implemented on the IOS version which I have. Sorry, i didn't realise the two versions were different and should have done this to start with. Thanks again for replying. S

more options

ps... Happy112 - just checked on my Windows 10 tablet and it is exactly as you say, under options, etc., but there is no 'options' in IOS and no 'dnd'.

more options

SoundFlyer said

ps... Happy112 - just checked on my Windows 10 tablet and it is exactly as you say, under options, etc., but there is no 'options' in IOS and no 'dnd'.

Your problem still isn't solved then, and yet you've marked my answer as 'Chosen Solution' ........ Fair is fair : you should remove that mark, while I'll keep my fingers crossed that somebody who knows how to stop this on IOS will come to your rescue (sorry  !)

more options

Hi SounfFlyer & Happy112,

I will remove the solved flag and move this post to the iOS section. (The links will stay the same it just makes it visible to the correct set of Helpers.)


Edit not solved, so removing solved flag from this answer

Изменено John99

more options

Thanks, John99 & Happy112 - Yes, it's still an irritating problem in the IOS version. It seems that is due to Apple restrictions on Mozilla's IOS implementation of Firefox. It would be very helpful, thouugh, and perhaps illuminating to find out if anyone has found a workaround. Sf