Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can you help my search engine provide search suggestions?

  • 8 ответов
  • 1 имеет эту проблему
  • 102 просмотра
  • Последний ответ от jscher2000

more options

Firefox is not providing suggestions when I start typing in the search field. I have "Provide Search Suggestions" checked along with "Show search suggestions in location bar". When I force quit Firefox and restart, suggestions will appear for my first 2-3 searches and then it goes back to not providing any suggestions. I'm frustrated! The search suggestions are super helpful because sometimes I don't even know the full extent of what I'm searching for until I see the suggestions.

I've attached 3 pictures...the first pic shows how I receive no suggestions, the second shows that my Firefox has the ability to show options before it quickly reverts back to showing none and the third shows that I have the proper boxes checked to enable "show suggestions"

ETA: I've spent 45 minutes waiting for one picture to load but I just keep getting this message: Uploading "google search with no options.png"... Can I email you the pictures that I'm referring to in the above inquiry?

Выбранное решение

The last screenshot definitely shows the problem. Next time this happens, could you try:

  • turn suggestions off, type some text, then turn it back on again (you can right-click the search bar to call up the context menu and make the change there)
  • check whether you get suggestions below the search bar in a new window (you can launch a new window using Ctrl+n)
  • check whether you get suggestions in the embedded search box on Firefox's new tab page (Ctrl+t)
Прочитайте этот ответ в контексте 👍 2

Все ответы (8)

more options

Sorry about the image uploading glitch. Can you attach them to a reply:

https://support.mozilla.org/questions/1147043#question-reply

more options

Hi, sorry to hear you are having a problem; please see if anything here helps - How to fix preferences that won't save.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Hi jscher2000,

Yes, I was able to attach them to a reply. Please let me know if I can provide additional information.

Thanks

more options

Google also gives me only one suggestion for firefox help desk -- the entire phrase -- so that first image matches my experience in Firefox's search bar. It's also what I get typing firefox help desk into a search box on Google's site. So I think that is correct.

Does Firefox stop retrieving lots of matches for shorter phrases? I'm not sure what would cause that. Unfortunately any errors messages that Google might send in the background are probably not logged anywhere.

more options

Yes, Firefox stops retrieving lots of matches for shorter phrases. I've attached a screenshot of a search I did last week of the word "tassel" which produced lots and results and the same search that I just did of the same word which produced no results. Sorry about all of this...it's just a bit confusing!

Thanks for trying to assist with this!

more options

Выбранное решение

The last screenshot definitely shows the problem. Next time this happens, could you try:

  • turn suggestions off, type some text, then turn it back on again (you can right-click the search bar to call up the context menu and make the change there)
  • check whether you get suggestions below the search bar in a new window (you can launch a new window using Ctrl+n)
  • check whether you get suggestions in the embedded search box on Firefox's new tab page (Ctrl+t)
more options

Yes, I get suggestions in the search box when I switch to a new window.

Thanks for your help!

more options

If a new window works reliably despite the problems in the first window, the problem sometimes is that a "global" plugin such as a security software plugin is set to the default permission of "Ask to Activate." Global plugins work best when set to "Always Activate" or if you prefer to turn them off, "Never Activate". It's a change you can make on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, see whether you have any plugins that need to run globally in the background and check their permissions. Plugins that web pages use to run their own content (e.g., Flash, Java, Silverlight, VLC, Adobe Acrobat) are best left on "Ask to Activate" so you can control which sites use them.