Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox ignores my printer presets.

  • 12 ответов
  • 3 имеют эту проблему
  • 13 просмотров
  • Последний ответ от Printing1

more options

When I print from Firefox, it ignores my printer preset -- "Plain paper, fast draft, black and white" -- and insists on printing in color. How can I get it to print web pages in black and white?

All Replies (12)

more options

Hi   !
Would you take a look at this article and see if you can find the solution there:
https://support.mozilla.org/en-US/kb/fix-printing-problems-firefox
If the solution isn't there,   we will just have to keep looking   .....

more options

Happy112, thanks so much. The article certainly looked promising, but, after having done everything it said to do, the problem still exists. Importantly, the first test -- seeing if I have the same problem in Safari -- revealed that this is in Firefox only.

more options

Hi   again   !
'Been searching and searching for an answer,   and only found solutions to the opposite of your problem:   FF wil   not   print in color   ......

Have you clicked the checkbox to enable   Print Background   (colors and images)   ? If so;   what if you   uncheck   that box   ?
(I don't have a printer,   so this is a complete stab in the dark for me)

more options

Thanks again -- I've really put you through it, and didn't mean to. Nah, the Print Background boxes are unchecked.

Let's hope someone else has an answer. I really appreciate your taking all the time to help. Thanks again.

more options

Printing1 said

Thanks again -- I've really put you through it, and didn't mean to.

Aww,   you didn't put me through anything,   you hear   !
I'm just so sorry that I haven't come up with a solution   ......

more options

I've called for help   .......   (fingers crossed   ! )

more options

I've called for help   .........   (fingers crossed   ! )

more options

Couldn't let it go and I just found this   (was chosen as a solution):
{ Ctrl + P } then open Properties for that printer. Then locate the Color / Grayscale toggle in the Print driver software.
Any good   ?
(somebody is bound to come to your rescue   !)

more options

You're terrific, thanks again. Alas, no. First of all, when I pressed {Ctrl + P}, there's nothing that says "Properties". (I have a MacBook Pro, if that makes a diffrerence.) But I did start fiddling around with that "Print" window, looking at Presets, Printer, etc. -- all to no avail. The Preset that I've been using says, for example, that it uses the black ink cartridge only, yet everything prints in color. If I print from the same Preset in Preview, Word, Safari, or anything else, it does the right thing and prints fast in black & white.

Thanks again for your help -- and your optimism that someone can help. Sure hope you're right!

more options

Bummer   !!!
Probably a very dumb question:   why don't you just use a black
ink cartridge   ? I am still hoping that maybe somebody will come up with a solution. Keeping my fingers crossed   .......

Изменено Happy112

more options

The short answer is that I do need to print some things in color, but, naturally, I don't want to use up the more expensive color cartridge for things that only need to be in b&w. The best work around is an inconvenience: I save the page as a .pdf, and print it from Preview.