Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

lost all firefox icons on htm &html files on desktop

  • 4 ответа
  • 1 имеет эту проблему
  • 17 просмотров
  • Последний ответ от mfitznet

more options

On my desktop I've lost all Firefox icons identifying html, htm, shtml, xht, xhtml files but other Firefox associated files have retained theirs. Firefox is my default browser. Have switched the default to IE, and the files show the proper IE icon, but switching it back to FF the icons are blank again. The files, themselves, are fine and if clicked on they open in Firefox the way they're supposed to, but the file icons are wrong.

Have tried changing the icon with the properties tab to no avail.

I posted this back in Oct 2015 and was reposted by others in Feb 2016 with a suggestion to rebuild the Windows icon cache (IconCache.db), which didn't appear to help. It appears that we still have no resolution.


Apparently I'm not alone with this problem, so how can we fix this and stop it from happening ?

Win Vista 64b. FF ver: 46.0.1

Thanks in advance for your assistance in this matter.

On my desktop I've lost all Firefox icons identifying html, htm, shtml, xht, xhtml files but other Firefox associated files have retained theirs. Firefox is my default browser. Have switched the default to IE, and the files show the proper IE icon, but switching it back to FF the icons are blank again. The files, themselves, are fine and if clicked on they open in Firefox the way they're supposed to, but the file icons are wrong. Have tried changing the icon with the properties tab to no avail. I posted this back in Oct 2015 and was reposted by others in Feb 2016 with a suggestion to rebuild the Windows icon cache (IconCache.db), which didn't appear to help. It appears that we still have no resolution. Apparently I'm not alone with this problem, so how can we fix this and stop it from happening ? Win Vista 64b. FF ver: 46.0.1 Thanks in advance for your assistance in this matter.

Все ответы (4)

more options

Right click one of the icons and select Properties. Select Web Document. Press the Change Icon button. Now the tricky part. Find; Look For Icons In This File and press the Browse button. Go to the C:\Program Files (x86)\Mozilla Firefox folder, then select Firefox.


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe Shockwave for Director Netscape plug-in, version 12.2.2.172 Adobe Shockwave for Director Netscape plug-in, version 11.5
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Shockwave Director: Shockwave Standalone Installer / Uninstaller{web link} Shockwave Director Version Version 12.2.4.194 http://get.adobe.com/shockwave/

more options

When I right click one of the desktop icons involved and select Properties, and Select Web Document it already shows the proper icon, in the Properties Tab, as representing this html file, it just doesn't show on the file itself.

If I follow your remaining steps and finally click on Firefox.exe nothing changes, still no icon on the file. That's what I meant when I said "Have tried changing the icon with the properties tab to no avail."

Maybe it has something to do with rebuild the Windows icon cache, but that didn't appear to help before.

Thanks, but still hoping!!

more options

You need to select the Firefox program. Its icons are then loaded on the screen. Click the one you want to use.

more options

Don't mean to keep going around in circles but as you can see from the attached images the firefox program is already selected for this html document. As said before I followed you previous suggestion, and nothing changed, still no FF icon on the file on my desktop.

Thnks again