Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

With FF as default browser, from TB click on link asks to close FF?

  • 17 ответов
  • 3 имеют эту проблему
  • 153 просмотра
  • Последний ответ от blugene

more options

Windows 10 FF 46.0.1 TB 45 When clicking on a link in TB, an error is passed stating to: "Firefox is already running, but not responding. The old Firefox must be closed to open a new window" See alarm screen.jpg

Приложенные скриншоты

Выбранное решение

I had two e-mail accounts that I manage with TB One account had the ProfilerSwitcher extension in it with this variable unchecked (It is checked by default). It worked. by clicking on a link in an email, FF opened it up just fine. However, the other e-mail account didn't have this extension installed and didn't work posting the original error message. Once I installed ProfileSwitcher and deslected the MO_NO_REMOTE parameter this account then worked

Windows 10 TB 45.1.1 FF 47.0

Прочитайте этот ответ в контексте 👍 0

Все ответы (17)

more options
more options

Did some testing and it doesn't seem to be from profiles I start up in "safe" mode and didn't help

more options

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).

more options

I'm not quite understanding you. Would this switch be set on install or update? I've attached screen shots of what I think you're referring to.

thanks in advance.

more options

No - not from the installation or from an update, it would be something the user set. The environment variable MOZ_NO_REMOTE=1 was deprecated years ago in lieu of a command line 'switch' of -no-remote for Firefox. Either of those could cause that message.

Check the full list in System variables for MOZ_NO_REMOTE=1 - scroll down.

more options

O.k so I added the MOZ_NO_REMOTE=1 to System Vars exited out of FF and attempted to open link again and got same error

more options

You shouldn't use MOZ_NO_REMOTE=1 as that will cause this error as well, so please undo this action.

The most likely cause of this error is still that the -no-remote switch is active somehow, so check all the shortcuts you use to start Firefox and maybe also try to search the Windows Registry for this switch.

more options

I kind of understand you. New computer Windows 10 I don't know how to get at the registry little alone find and fix these issues any direction will help

more options

Can anyone please help me?

more options

Can someone help me please? I really don't like to use IE

more options

It sounds like you did something to Firefox or in Windows10 which created that problem; namely either the desktop shortcut for Firefox has the -no-remote command line switch or you added (and haven't yet removed) the MOZ_NO_REMOTE=1 from System Variables.

Did you inspect the "Target:" line for that -no-remote switch in the Firefox desktop shortcut? Did you delete that System Variable?

more options

I don't see anything with the shortcut "Target:"

 "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

I also don't see the MOZ_NO_REMOTE=1 in the System Variables.

more options

Can someone please help me?

more options

How about that MOZ_NO_REMOTE=1 System Variable?

As you posted in the screenshot.

more options

There is an add-on to TB that has this variable The "Profile Switcher" https://addons.mozilla.org/en-US/thunderbird/addon/profileswitcher/?src=ss The default is checked but I have unchecked it. But still have the same problem Note that this is not part of the system VARS

more options

Maybe your problem is with Thunderbird, and possibly with that Profile Switcher extension in Thunderbird?

Have you searched the Windows Registry for that System Variable? I can't help you with that as I haven't 'messed with' the Registry since the days of Win98. http://www.tenforums.com/

more options

Выбранное решение

I had two e-mail accounts that I manage with TB One account had the ProfilerSwitcher extension in it with this variable unchecked (It is checked by default). It worked. by clicking on a link in an email, FF opened it up just fine. However, the other e-mail account didn't have this extension installed and didn't work posting the original error message. Once I installed ProfileSwitcher and deslected the MO_NO_REMOTE parameter this account then worked

Windows 10 TB 45.1.1 FF 47.0