Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

I accidently turned my text color to white and now I cannot see anything. How do I get back?

  • 5 ответов
  • 3 имеют эту проблему
  • 2155 просмотров
  • Последний ответ от FredMcD

more options

Since my text color is white I just get a blank screen. Right now I am using internet explorer to communicate. My Firefox is completely useless because my screen is just white.

Выбранное решение

The three solutions were all helpful. No single one seemed to have all the info I needed, but from the information in the three of them I was able to resolve the problem. Thanks, I appreciate all the help.

Прочитайте этот ответ в контексте 👍 1

Все ответы (5)

more options

How did you change the color? If you used an add-on;

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox.

Then change what needs to be changed back.


NoSquint {web link} NoSquint allows you to adjust the text-only and full-page (both text and images) zoom levels as well as color settings both globally (for all sites) and per site.

more options

You're not the first person to do this! The simplest approach is to rename the settings file that stores text and background colors. Then Firefox will start using the default colors. I'll describe a different method in the next post that affects fewer settings if you want to try that one first.

Rename prefs.js

First, make sure Firefox is fully closed. If necessary, you can right-click its icon on the taskbar and choose Close Window or Close All Windows.

Next, open your Firefox profile folder. In the Windows 10 search box, type or paste the following and press Enter to load it:

%APPDATA%\Mozilla\Firefox\Profiles

Here you may find one semi-randomly-named folder, in which case, go ahead and click into it, or you might find two or more, in which case, explore around and find the most recent.

That semi-randomly-named folder is your profile folder, and the prefs.js file in that folder is the one you'll want to rename.

Note: if you do not see the .js extension on the prefs file, you can set Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Right-click prefs.js and choose Rename and change it to something like prefs-old.js -- to keep it around for future reference. Then start Firefox up again and it should be back to normal colors.

Alternately, if you want to try to edit the prefs.js file:

Instead of renaming the file, right-click prefs.js and choose Edit to open it in Notepad (most likely), then then use the editor's Find or Search command to look for this preference:

user_pref("browser.display.foreground_color", "#FFFFFF");

Carefully edit FFFFFF (six Fs = white) to 000000 (six zeros = black) and save the change. If your editor wants to convert the document to a rich text format, make sure to override that and use a plain text format (but without adding a .txt to the file name). Then close the editor.

When you start Firefox, it should read your updated settings file.

more options

Actually, rather than paste lots of text here, I'll link you to the other method: https://support.mozilla.org/questions/1113222#answer-852757

more options

Выбранное решение

The three solutions were all helpful. No single one seemed to have all the info I needed, but from the information in the three of them I was able to resolve the problem. Thanks, I appreciate all the help.

more options

Glad to help. Safe Surfing.