Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Spellcheck doesn't work in English (US) mode, underlines all words red and doesn't show any possible words.

  • 4 ответа
  • 1 имеет эту проблему
  • 7 просмотров
  • Последний ответ от Melody.Mel

more options

I downloaded Firefox in my native Lithuanian, however no other spell check dictionaries work other than Lithuanian one that came with Firefox. Tried to delete and re-add dictionaries and language packs, made sure that the correct one was chosen. However it just underlines all words red, but doesn't give me any options to choose from once i right-click on them (I only get options when I pick Lithuanian). Also tried reinstalling Firefox, as well as getting an English version, but it didn't work. I used US one before getting a new computer and it worked just fine, it also works on other browsers, but Firefox is the only one I'm having issues with in regard to spell check. Thank you.

Выбранное решение

Doesn't installing the Firefox en_US version as a custom install in a different install location work as well?

Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Прочитайте этот ответ в контексте 👍 1

Все ответы (4)

more options

Do you see the English dictionary as a choice in the Languages menu once you have installed this dictionary?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

You can check the spellchecker.dictionary pref on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Yes, I see all the dictionaries that I installed (tried British one once US didn't work), but when I pick any other than Lithuanian they simply don't work. For example: I chose the US one and as I type here every word is underlined in red as if it's incorrect, yet when I right click it doesn't give me any options of a word on any word (unless I switch to Lithuanian spell check). I just checked the about:config setting and it says "lt".

more options

Выбранное решение

Doesn't installing the Firefox en_US version as a custom install in a different install location work as well?

Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I tried creating a new profile in the existing AppData folder, but it didn't fix it, so I created another in a different place and it worked! Moved all the files from existing profile to the new one and everything works now. Thank you! Also, realized the problem is probably in the path as my User folder contains a non-english letter, yet I can't change it.