Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

I've turned off everything related to junk. I've set the Inbox as junk folder. Etc. I cannot get messages out of Junk.

  • 5 ответов
  • 5 имеют эту проблему
  • 40 просмотров
  • Последний ответ от Toad-Hall

more options

I do not want Thunderbird to do anything with what it THINKS is junk, but I cannot seem to keep certain messages from being sent to Junk. I have unchecked every junk setting. I have enabled adaptive controls, white listed collected addresses and personal. I have even tried moving junk to the Inbox. Nevertheless, there are messages in the junk folder that cannot be moved. I have tried checking and unchecking junk. I have tried checking junk and then telling Thunderbird it is not junk in the heading. I have moved the mail from the junk folder to the inbox. No matter what I do certain messages keep going to junk, and if I move them out, no matter HOW I move them out, they immediately reappear in the junk folder. Note in the mailbox image that most of these messages came from the same email address while one of them was moved from my other email folder on Thunderbird (where, BTW, it was NOT marked as trash. Thanks for your help.

Выбранное решение

re :Even with RoundCube I can't get these emails out of the Junk folder. That makes me think it is not Thunderbird.

If you can see emails in roundcube Junk folder, then it is an Imap Junk folder which you have subscribed to see in Thunderbird and not Thunderbird's Junk Folder. Maybe you have filters in webmail account that are dictating what is Junk/spam.

Прочитайте этот ответ в контексте 👍 2

Все ответы (5)

more options

re : I have unchecked every junk setting. I have enabled adaptive controls, white listed collected addresses and personal.

If you have enabled adaptive controls then you need to train Thunderbird to recognise what is and isn't Junk. As you have good emails in Junk then it sounds as if you didn't go through this procedure initially when you set up the mail accounts.

Please note, I am referrring to the Thunderbird 'Junk' folder and not an imap subscribed Junk folder.

Try this to stop anything being sent to 'Junk'. Go into 'Offline' mode to stop Thunderbird connecting with server(s).

'Tools' > 'Options' > 'Security' > 'Junk' tab

  • click on 'Reset Training data' button to clear current training info.
  • click on OK

Junk folder for each mail account. Right click on emails and select 'Not Junk'. Emails should be auto returned to the Inbox. When Junk is empty - right click on Junk folder and select 'Compact'.

'Tools' > 'Options' > 'Security' > 'Junk' tab

  • uncheck: When I mark messages as Junk'
  • uncheck: 'Mark messages determined to be Junk as read'
  • uncheck: 'enable adaptive junk filter logging'
  • click on OK

Tools > Account Settings > Junk Settings.

  • uncheck 'enable adaptive junk mail controls for this account'
  • uncheck: 'Move new Junk messages to'

Do this for all accounts and click on OK.

Then go back to 'online' mode.

Please report back on results.

Изменено Toad-Hall

more options

I have already done all of those things repeatedly. I have even done a few other things, like putting my Inbox as the junk folder. I don't know for sure, but I am now thinking that my imap mailbox is doing this. Thunderbird lets me move the email out of Junk and into the Inbox: then it reappears in junk. Thunderbird lets me mark the email as "Not Junk" and move it, but it then reappears in Junk almost instantly. Yesterday, I turned Thunderbird off completely and started using my webmail client (RoundCube). Even with RoundCube I can't get these emails out of the Junk folder. That makes me think it is not Thunderbird.

more options

Выбранное решение

re :Even with RoundCube I can't get these emails out of the Junk folder. That makes me think it is not Thunderbird.

If you can see emails in roundcube Junk folder, then it is an Imap Junk folder which you have subscribed to see in Thunderbird and not Thunderbird's Junk Folder. Maybe you have filters in webmail account that are dictating what is Junk/spam.

more options

Hello, I have already done ALL of what 'Toad'Hall' suggests, but it does NOT work (TB 45.2.0) - REGARDLESS of what I do with the 'junk settings', the 'adaptive SPAM filter LOG' remains EMPTY - it NEVER has ANY entries, hence to "reset data" does ABSOLUTELY NOTHING! In my case, mails from MY BEST FRIEND, as well as important documents about online PURCHASES are marked as "junk", and if I mark them as "not Junk", they get re-junked automatically within a few seconds. Surely, it should be up to the END USER, to decide what s/he regards as "Junk"! What would you think, if I come along and take mail out of YOUR post box, because I think "it's junk", and YOU don't need it?! I'd be a CRIMINAL doing so . . . The same is true of ANYBODY (incl,. software) that mis-treats MY mail!! There should be an OVERRIDE button (or a WORKING "NOT JUNK" setting!), since Thunderbird is the LAST software, that determines any mail's 'junk' status, and (I repeat:) the END USER is the ONLY one, that legally has the right to determine, if s/he wants a certain mail or not! PLEASE FIX THIS - or Thunderbird will get the "JUNK" status from me!

more options

roc1-1 As this question is already marked as solved because in this instance imap account was being effected by roundcube, you would need to ask your own question.

What you have done is effectively send an email to the person who originally asked this question. I also got a response purely because I had not stopped following this solved query. A new question would get the attention of the entire community, not just two people, so it would be more beneficial to you. When you create a new question please post useful information, such as whether you use imap or pop and post 3 images showing the Account Settings Junk Settings for the account effected and the settings in Options > Security > Junk tab and the 'Folder Pane'. BTW: Using capital letters is considered as shouting and not appreciated by anyone.