Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

I changed my background and my text color in black, how to fix it? Reinstalling doesn't help. Can't see options.

  • 3 ответа
  • 6 имеют эту проблему
  • 508 просмотров
  • Последний ответ от enko

more options

everything is black on my mozilla firefox screen now, only links are blue.. I can't see to change my background to white or my text color to white... Please help, i tryed reinstalling, it doesn't help, it's the same thing

Выбранное решение

You're not the first person to do this! The simplest approach is to rename the settings file that stores text and background colors. Then Firefox will start using the default colors. I'll describe a different method in the next post that affects fewer settings if you want to try that one first.

Rename prefs.js

First, make sure Firefox is fully closed. If necessary, you can right-click its icon on the taskbar and choose Close All Windows.

Opening your Firefox profile folder. In the search box on the Windows 7 Start menu, type or paste the following and press Enter to load it:

%APPDATA%\Mozilla\Firefox\Profiles

Here you may find one semi-randomly-named folder, in which case, go ahead and click into it, or you might find two or more, in which case, explore around and find the most recent.

That semi-randomly-named folder is your profile folder, and the prefs.js file in that folder is the one you'll want to rename.

Note: if you do not see the .js extension on the prefs file, you can set Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Right-click prefs.js and choose Rename and change it to something like prefs-old.js -- to keep it around for future reference. Then start Firefox up again and it should be back to normal colors.

Alternately, if you want to try to edit the prefs.js file:

Right-click prefs.js and choose Edit to open it in Notepad (most likely), then then use the editor's Find or Search command to look for this preference:

user_pref("browser.display.background_color", "#000000");

Carefully edit 000000 (six zeros = black) to FFFFFF (six Fs = white) and save the change. If your editor wants to convert the document to a rich text format, make sure to override that and use a plain text format (but without adding a .txt to the file name). Then close the editor.

When you start Firefox, it should read your updated settings file.

Прочитайте этот ответ в контексте 👍 1

Все ответы (3)

more options

Выбранное решение

You're not the first person to do this! The simplest approach is to rename the settings file that stores text and background colors. Then Firefox will start using the default colors. I'll describe a different method in the next post that affects fewer settings if you want to try that one first.

Rename prefs.js

First, make sure Firefox is fully closed. If necessary, you can right-click its icon on the taskbar and choose Close All Windows.

Opening your Firefox profile folder. In the search box on the Windows 7 Start menu, type or paste the following and press Enter to load it:

%APPDATA%\Mozilla\Firefox\Profiles

Here you may find one semi-randomly-named folder, in which case, go ahead and click into it, or you might find two or more, in which case, explore around and find the most recent.

That semi-randomly-named folder is your profile folder, and the prefs.js file in that folder is the one you'll want to rename.

Note: if you do not see the .js extension on the prefs file, you can set Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Right-click prefs.js and choose Rename and change it to something like prefs-old.js -- to keep it around for future reference. Then start Firefox up again and it should be back to normal colors.

Alternately, if you want to try to edit the prefs.js file:

Right-click prefs.js and choose Edit to open it in Notepad (most likely), then then use the editor's Find or Search command to look for this preference:

user_pref("browser.display.background_color", "#000000");

Carefully edit 000000 (six zeros = black) to FFFFFF (six Fs = white) and save the change. If your editor wants to convert the document to a rich text format, make sure to override that and use a plain text format (but without adding a .txt to the file name). Then close the editor.

When you start Firefox, it should read your updated settings file.

more options

Renaming or editing the prefs.js file is actually the easiest approach to removing this problem, but you could try this, which forces Firefox to ignore your color selections in enough places to let you select different colors on the Options page. There are screen shots for illustration:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Press Enter to "click" the button promising to be careful.

(2) At the top of the page is a search box, you'll have to "blind click" to hit it. In the search box above the list, type or paste document_color and pause while the list is filtered (which you won't be able to see, but stay with me here).

(3) The browser.display.document_color_use preference is listed invisibly below the row with the vertical white lines. Right-click in that area and you should get a context menu with Modify as the top option. Click Modify or, if you cannot see it, try pressing M to activate it.

(4) A visible pop-up should allow you to edit the current value, usually 0, possibly 2 -- make a mental note -- to a 1 and then click OK. Immediately you should see black text on a white background again.

Now you can go back to the Preferences page and select the colors you actually wanted. Then the last step is to undo the change you made in about:config. On the Preferences page, you then can restore your earlier setting:

Override the colors specified by the page with my selections above: 0 = Only with High Contrast themes 1 = Never 2 = Always

more options

Guys, THANKS A LOT! You are awesome, it's all back like it was before. Thank you all...