Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I rename all bookmarks so that they display the page title instead of the URL?

  • 8 ответов
  • 1 имеет эту проблему
  • 20 просмотров
  • Последний ответ от cor-el

more options

When I bookmark all my tabs in a session using the CTRL+SHIFT+D hotkey, it automatically creates a folder of all the tabs. The folder that is automatically created with that hotkey, however, only displays the URL instead of the page title. It adds difficulty when choosing bookmarks, since only the URL is shown, and not the title of the webpage.

Все ответы (8)

more options

Hmm, I tested this and it seems to be working on my Firefox. I pressed Ctrl+Shift+d and got a dialog asking for a folder name. I entered TEST and clicked Add Bookmarks. Then I looked at the TEST folder on the Bookmarks menu, and the items in the folder were listed by title as expected. Note: these are the tabs in the current window only, not in all the windows in my session.

Are you using any add-ons that might be modifying how this feature works?

more options

No, I have no add-ons enabled as of right now. This has been an ongoing issue for about a year now. The feature works, it just displays the URL of the page as the bookmark name and I would like it to display the webpage title. All of my bookmarks from YouTube for example, have the name of "http://www.youtube.com/..." and it is difficult to distinguish which bookmark is which as I have hundreds. There is no way to program it through even developer tools (which I am unfamiliar with) in order to rename all bookmarks to their proper page title?

more options

Firefox normally does use the page title as the name. It should only use the address if there is no page title. YouTube definitely has page titles.

If you right-click a bookmark and check its Properties, does it show the correct information in the Name field? In other words, is this a problem with how Firefox created the bookmarks, or is this a problem with how they are displayed on the menu?

more options

This can happen if you haven't visited the tabs in the current session, either because you restored the previous session or you opened links in the background.

more options

jscher2000 said

Firefox normally does use the page title as the name. It should only use the address if there is no page title. YouTube definitely has page titles. If you right-click a bookmark and check its Properties, does it show the correct information in the Name field? In other words, is this a problem with how Firefox created the bookmarks, or is this a problem with how they are displayed on the menu?

When I click Properties, the only thing that doesn't have an empty field is the Location, which is the URL. These are only for tabs that I've bookmarked when using CTRL+SHIFT+D, which creates a folder. The bottom line is that it's safe to say that I have even over a total of 50 folders with over 400 bookmarks. Sifting through each folder I've created with that many bookmarks would be a chore, as I have to click and see which bookmark is what, and then rename each one through the Bookmark properties menu.

cor-el said

This can happen if you haven't visited the tabs in the current session, either because you restored the previous session or you opened links in the background.

I always make sure webpages are loaded before I bookmark them because I HAVE had that problem and I know what you're talking about!

Thank you guys, but there has to be a way to do this! I have found no add-ons for Firefox which support this feature thus far. Although, I have found one page that maybe you guys or someone can help me with. It's for developers/programmers though, and I am very inexperienced in that field/s, but I am almost positive it is the solution to my exact problem for programming every bookmark to display the webpage title instead of the URL. So bottom line is, to my knowledge, there is no solution to this issue, to my knowledge, without programming, which I don't understand at all!

nsINavBookmarksService - The BookmarksService interface provides methods for managing bookmarked history items. Bookmarks consist of a set of user-customizable folders. A URL in history can be contained in one or more such folders. https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XPCOM/Reference/Interface/nsINavBookmarksService

Thanks again guys!

more options

There are URL-checking extensions which go out to the web to see whether your bookmarks are still valid. I don't know whether they will update the Name field with the current page title but, if you find one that can, that would certainly be faster than the alternative of doing it by hand.


Since Ctrl+d works normally but Ctrl+Shift+d has this problem, it's possible there is some program file corruption. For that we suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 44.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox "bookmark all tabs" normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Yes, it still didn't solve the CTRL+SHIFT+D problem. The bookmarks in the folders that are made through this hotkey still display only the URL and not the page title. I am not experienced at developing, but may there be any chance it could be how the hotkey was coded or programmed into Firefox? Maybe it could be updated to work with that specific hotkey?

However, I found a page on Mozilla Developer Network (MDN). I found a specific command in a bookmarks service titled 'nsINavBookmarksService' to change all bookmarks to display the page title instead of the URL and it seems like this service could be my answer. I just don't know how to use Developer Mode maybe somebody could walk me through the process of executing this command. https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XPCOM/Reference/Interface/nsINavBookmarksService


The CTRL+SHIFT+D hotkey I will experiment with to see if it works after I do a clean uninstall/install. For now, I found that the Bookmarks Sidebar, Bookmarks Toolbar, and the Pin Tab button help access/sort bookmarks more readily.

Изменено flstudioacidpro

more options

You can check for problems with the places.sqlite database (bookmarks, history) in the Firefox profile folder.

Be sure to keep a backup copy of places.sqlite in case a new places.sqlite database has to be created