Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I change the new behaviour of the location bar dropdown menu regarding which url comes up first?

  • 3 ответа
  • 3 имеют эту проблему
  • 3 просмотра
  • Последний ответ от cor-el

more options

Since upgrading to FF43, the location bar behaves differently. If I type a letter, urls are shown containing that letter. In FF42 the first result would be whatever url I visited the most, containing that letter in it's url. Now in FF43 it always is a url that starts with the letter I typed. These are often not the same. I now constantly click on the wrong entry because I am so used to just quickly click the first one out of habit.

If a site's url starts with the letter I typed, and is also the site I visit the most, it now doubles up the results! For instance, if I type the letter H, my first result is: "Visit hardocp.com", and directly below it is an entry: "www.hardocp.com". That whole "Visit hardocp.com" result is new behaviour that I would very much like to disable.

Also, deleting an entry from the location bar doesn't seem to work anymore (The one that comes up first now, and always starts with: "Visit [url]"). I highlight the entry and hit delete on my keyboard and it disappears. I then have my most visited url as my first result again. But when I then refresh and revisit the location bar and type a letter, the entry is back! It is infuriating.

How do I go about fixing this?

Выбранное решение

That's a new feature in Firefox 43. To turn it off do this:

  1. Go to about:config in Firefox
  2. Click the I'll be careful button
  3. Locate the browser.urlbar.unifiedcomplete boolean
  4. Change the value to false

Note: You may need to restart Firefox for the changes to take effect.

Прочитайте этот ответ в контексте 👍 3

Все ответы (3)

more options

Выбранное решение

That's a new feature in Firefox 43. To turn it off do this:

  1. Go to about:config in Firefox
  2. Click the I'll be careful button
  3. Locate the browser.urlbar.unifiedcomplete boolean
  4. Change the value to false

Note: You may need to restart Firefox for the changes to take effect.

more options

Note that his is not really a new feature, but it has been enabled in Firefox 43 by default.