Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Since the latest upgrade, Firefox is slow and crashing. WHY.

more options

Firefox asked me to upgrade to the latest version. I did. Since I did, it has been hugely slow, choppy, crashing and generally such a pain I am considering moving over to Chrome. I did NOT refresh, but I am having the exact same problems in Safe mode. I am running Windows 7. My husband also uses Windows 7, just upgraded his Firefox (against my advice) and is now having the same issues.

Firefox asked me to upgrade to the latest version. I did. Since I did, it has been hugely slow, choppy, crashing and generally such a pain I am considering moving over to Chrome. I did NOT refresh, but I am having the exact same problems in Safe mode. I am running Windows 7. My husband also uses Windows 7, just upgraded his Firefox (against my advice) and is now having the same issues.

Все ответы (1)

more options

You probably saw our general article on Firefox being slow: Quick fixes if your Firefox slows down.

Sorry to hear about the crashes. If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.


If your Firefox is not literally crashing but is frequently "Not Responding", then unfortunately crash data usually is not captured.

We do have a support article on "Not Responding" problems: Firefox hangs or is not responding - How to fix.

Since the Flash plugin also can cause this problem, and is not disabled in Safe Mode, it's worth trying a couple things to minimize potential issues with Flash during your troubleshooting:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.