Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop firefox from loading a third-party file at startup causing it to redirect?

  • 3 ответа
  • 64 имеют эту проблему
  • 17909 просмотров
  • Последний ответ от DraconicEpic

more options

One of my family member recently install some a freeware program on my computer and now I have an issue where it is basically hijacked my browser. For the most part, I've fixed all the problems except one: when ever my browser starts, it attempts to load an external file, which I've deleted for obvious reasons (Actually the whole directory it existed in), that redirect to a search engine, which no longer happens because the file was deleted. I didn't get any hits for any part of the file path in the about:config so I assume it's clean. I copied over a profile from a completely different computer to insure there isn't any junk in there. Finally, I've already ran an Anti-Virus scan and two Adware cleanup programs. Regardless the startup settings, I always start up to a "You can't open file:///C:/ProgramData/Bamcofs/snp.sc" which overall doesn't seem to be a problem, but it is rather annoying.

P.S. I rather not have to reinstall unless it is absolutely needed.

Выбранное решение

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

Прочитайте этот ответ в контексте 👍 5

Все ответы (3)

more options

DraconicEpic said

I rather not have to reinstall unless it is absolutely needed.

Reinstalling the Firefox program is not a real bother. Your user profiles are stored elsewhere on the hard drive.


There are several things to check.

You may have corrupt sessionstore file(s).

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the sessionstore file(s). Then rename or delete them. Restart Firefox. +++++++++++++ Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display. Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want displayed.

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

more options

Выбранное решение

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

more options

cor-el said

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You were right! The program hacked the program shortcut in the start menu. When I opened Firefox from the installation directory to bypass it, it worked fine. Simply re-pinning the program fixed it.