Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I stop Flash from freezing Mozilla?

  • 4 ответа
  • 1 имеет эту проблему
  • 6 просмотров
  • Последний ответ от cor-el

more options

It's happened periodically before, Flash makes my browser hang for a time, sometimes I get the message to stopp a script from running, and all works ok again, but for the past few days, any website with flash videos is causing Firefox to hang, and the only way to get it going is to close and restart, and it immediately freezes again.

I've chosen to not enable Flash, and things work fine, but even if I choose "ask to activate" Flash, it still cause the browser to hang as soon as I try to watch the video.

Все ответы (4)

more options

Sorry, but this most likely is due to the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

I searched a little further after posting this. I went ahead and added Adblock+ and Flashblock to my browser, and it seems to be working ok for now. Some minor issues as I figure out how to get some videos I want to see to play, but over time I think I'll get the hang of it.

I may disable these two for a bit and try your suggestion, and see if that works also.

more options

Just checked, and I'd already unchecked that the other day, and still having issues. Guess I'll stick with what's working for now.

more options

You can check for issues caused by plugins and set plugins to "Ask to Activate" on the "Firefox menu button/Tools > Add-ons > Plugins" page.

  • plugins are not affected by Firefox Safe Mode

You can check for problems with current Shockwave Flash plugin versions and try this:

See also: