Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot copy and paste properly or edit pasted text

  • 20 ответов
  • 21 имеет эту проблему
  • 2848 просмотров
  • Последний ответ от jscher2000

more options

for the past few weeks Firefox has been really hard to Copy & Paste text from one page to another, then editing the text is impossible - I can paste lines of text but only one goes in the box - then when I try to edit or manipulate the text it just screws up :/

It does not matter if I use context menus or Keyboard commands to copy & paste (CTRL C& V)

I've been using Firefox for about 10 years and NEVER had this issue - I have tried the stuff in ABOUT:CONFIG CONTEXT and even in SAFE MODE the issue exists :/

I tried to screen record the fault but that's pointless because you cant see that my key presses are being totally ignored in the text box - all you would hear is me swearing the computer

Anyone else having this issue?

WTH is happening

I don't want to switch browsers as all my devices sync but this is getting really bad and makes working on my business blog virtually impossible.

Been in I.T. for 28 years and never seen anything like this before!

Все ответы (20)

more options

The issue seems more prolific in Facebook and Youtube

When I paste in replies I get double text then I cannot edit it properly, it shows double of everything - but only a single version is posted - its crazy :/

more options

At first, I thought your issue was this;

RightToClick {web link} Stops javascript annoyances such as forbidden right click, forbidden text selection or cascading dialog boxes.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

No, nothing related to that at all

more options

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

As I said in my original post:

I have tried the stuff in ABOUT:CONFIG CONTEXT and even in SAFE MODE the issue exists :/
more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Tried all combinations of computer and firefox in safe mode and the problem still exists.

Image attached shows the steps taken to produce the problem

more options

I have this problem also. I've tried running Firefox in safe mode...same problem. IE11 and Chrome do not have this problem.

more options

Can you post a public link to the page(s) you have the problem?

Have you tried using Windows Internet Explorer?


After the above,

Download Firefox Full Version For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

more options

So if I read you right FredMcD what you suggest is do is a clean install of firefox?

BTW I noticed I've failed to mention that the example I gave was facebook, but similar issues exist on youtube too.

more options

I should also mention this problem occurs on all 4 of my computers all running windows 7, firefox 40.0.3. Other browsers work fine. Any combination of safe modes the problem still exists and is perfectly repeatable. I will try a fresh install tonight (about 10 hours from now)

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Cor-el I just tried windows and firefox in safemode on my storage server using a login that has never been used (was created for network file sharing) and again the bug is repeatable. Is that a satisfactory test?

Running summary Bug is easily repeatable on facebook. Pasting causes two graphical appearances of the pasted text. Text is then further corrupted by any normal typing action. Pressing escape the text remains when it should not and is graphically corrupted (text over text) Windows 7, firefox 40.0.3, multiple systems (4) and user logins all exhibit the exact same issue. Safe modes of any combination (windows & firefox), issue still repeatable. No other browser has this issue on any of my (4) systems. Problem does not exist on this forum.

Edit: Tested for this bug at work: firefox 40.0.3, windows 7, problem does not exist! Very interesting, is there some way I can export config of firefox from my work PC and compare to the config I have at home?

Изменено atleastitsnotcrack

more options

In another thread (https://support.mozilla.org/en-US/questions/1080597) on not being able to paste in youtube the suggested fix (change "dom.event.clipboardevents.enabled" to false in about:config) resolves the problem of not being able to post in youtube, but it causes the paste problem I'm seeing in facebook (everything pasted twice, facebook doesn't recognize links)

I see a few recent bug reports but no resolutions in the bug list, but nothing spicific to this problem.

Изменено Steve E

more options

The Facebook comments box is a heavily scripted element. I don't know why they don't just use a normal form control... I'm sure they have their reasons. Please report this problem to Facebook so they can try to fix their script. I don't know whether they fixed the spellcheck issue yet (Spellcheck moves the word when you try to allow it to correct spelling errors in Facebook).

more options

Facebook Comment Box: The problem occurs when the very first input into the box is a paste. As a temporary workaround, click into the box, type any character, then paste. You can edit the extra character after that.

more options

jscher2000 said

Facebook Comment Box: The problem occurs when the very first input into the box is a paste. As a temporary workaround, click into the box, type any character, then paste. You can edit the extra character after that.

That does solve the double post problem (w/ dom.event.clipboardevents.enabled set to "false" ), but facebook still won't recognize the link in that configuration.

Since I copy and paste in Facebook a lot more than in youtube I'll have to leave dom.event.clipboardevents.enabled set to "true" Everyone else will have to decide which is more important to them (or use a different browser) until this bug is corrected.

more options

Hi guys, sorry for the late reply but been away for a few days

I have made a short video clip to demonstrate this issue

https://youtu.be/8E0N1rPhDfo

Even in Windows safe mode it's the same, no matter if Firefox is in safe mode or not either, the bug is here to stay :/ Looks like its time to try a new browser - gutted as FF syncs between all my devices (7 in all) so will be a pain the arse to move but this is crazy!

more options

Hi skpManiac, I was playing with Facebook status and comments, trying different things, reloading, and suddenly I can no longer reproduce the phantom-double-paste error. Could you reload your newsfeed page using Ctrl+Shift+r (this bypasses cached files) once or twice and see whether you still have the issue with a fresh set of files?

Edit: I'm testing in Firefox 41 on Windows 7.

Edit #2: I use the default setting of dom.event.clipboardevents.enabled=true

Изменено jscher2000

more options

Its exactly the same mate, nice try though

Tried once, then tried multiple times

I just updated to 41 and that's the same too, was very hopeful when I noticed the new version that they has resolved this :/

I have changed the setting back to TRUE and YES that does seem to resolve this double posting issue in Firefox 41 BUT how does it work in YouTube (that was the reason it was changed to False in the 1st place) I will test later (after work)  :)

Thank you

Изменено skpManiac

more options

Hi skpManiac, if YouTube is still a problem, you can block Google's paste interception script there with a userscript. See: https://support.mozilla.org/questions/1080597#answer-783815