Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

https://support.mozilla.org/ comes up as a blank page on FF 40.0.3, as do other locked sites.

  • 15 ответов
  • 1 имеет эту проблему
  • 14 просмотров
  • Последний ответ от Tonnes

more options

The mail support.mozilla.org page comes up blank in Firefox. If I use Chrome, it will display!!! In fact, in order to register with Mozilla support to ask this question, I had to use the Chrome browser! Unfortunately, the same is true for many sites with the green lock on the address. They will not display in Firefox but will in Chrome. As FF is my default browser, this is extremely annoying and has only started with the latest versions of the browser. Is there a fix for this problem? Thank you.

Все ответы (15)

more options

Is this an issue with a secure (https) connection?

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate.

more options

Thank you for your rapid reply, but I have no problem with Chrome at all. The problem is in Firefox, which opens with blank pages for most of the green padlocked sites, whereas when I use Chrome I can see the content. In any event, I will try putting in an exception in the Firefox browser for https://support.mozilla.org/ to see if that helps.

I did so, and the page is still blank in Firefox and working in Chrome. The problem persists.

more options

tianneis said

Thank you for your rapid reply, but I have no problem with Chrome at all.

Nobody said so, please read carefully and follow the instructions. By "Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

   chrome://pippki/content/exceptionDialog.xul "

...cor-el instructed you to do this in Firefox.

A browser chrome is a euphemism for the graphical framework and elements of a web browser window and has always been called that way in Mozilla software.

If you did understand this and managed to add the exception anyway, did you try clearing your cookies and cache, as well as using Safe mode?

more options

Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no connection with Google Chrome).

more options

Built-in error pages shouldn't be blank. There is a preference to pop up an alert for an error instead of displaying a page, but I can't think of any reason you would have turned that on. Also, you didn't mention getting a pop up alert. Still, you could check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste error and pause while the list is filtered

(3) If the browser.xul.error_pages.enabled preference is bolded and "user set" to false, double-click it to switch it back to true


Two other possible issues:

(1) Extension conflict (2) Corrupted update

For the first issue, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?


For the second issue, the usual recommendation is:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 40.0.3 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in (A). It should automatically connect to your existing settings.

Any improvement with the toolbars?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Thank you to everyone for your help. I am not a computer expert at all, but just a little old lady who really enjoys using her computer for a myriad of things. I believe, in this case, misinterpreting "chrome" references for the browser itself was a legitimate mistake, especially since I had mentioned Chrome in my problem. Aside from that, it seems that the blank page can be overridden (at least when doing a Google search), by "right click, open link in a new tab", instead of just clicking on the link and opening a new window, invariably blank. The tab solution opens the correct page with all its information. This also seems to be the case when right clicking links and opening in a new tab from other web sites, too. In view of this, I would consider the problem solved and thank all of you once again.

more options

I think I misunderstood the problem. Here --

tianneis said

Aside from that, it seems that the blank page can be overridden (at least when doing a Google search), by "right click, open link in a new tab", instead of just clicking on the link and opening a new window, invariably blank. The tab solution opens the correct page with all its information. This also seems to be the case when right clicking links and opening in a new tab from other web sites, too.

If you decide it's inconvenient to open links in a new tab, I'm interested to know more about what's in the address bar of the blank page.

In some cases, the problem might be caused by a tracking script. When you get a blank page from clicking a Google result, does it show a URL similar to this:

https://www.google.com/url?blahblah

Possibly some security or privacy add-on or external software is blocking that exit tracking script, or blocking the redirect that follows.

more options

jscher2000 said

If you decide it's inconvenient to open links in a new tab, I'm interested to know more about what's in the address bar of the blank page. In some cases, the problem might be caused by a tracking script. When you get a blank page from clicking a Google result, does it show a URL similar to this: https://www.google.com/url?blahblah

To answer your question, when using Google search and clicking directly on the link, at first there is a URL https://www.google.com/url?blahblah, as you say, but the address line loads quickly and becomes https://support.mozilla.org/ (for example), showing a blank page, however, as in the attached image for my original question. If I right click and choose to open in a new tab or window, that same page fills out with its complete information. The same is true for certain links on Yahoo News and others. I hope this is what you wanted to know.

more options

Hmm, I don't know what's causing it. I've seen reports on Google's forums for similar problems in IE from time to time, so I've always suspected some kind of security software. When you get the blank page, does reload (Ctr+r) work?

more options

Not at all. It's just stuck like that until I go back to the original link and right click/open in new tab or window. This is in Win 10, but it's the same on my other computer in Win 7 (the one from which I sent this query originally), and started with the newer versions of Firefox. Firefox extensions installed that theoretically might influence this could be Ghostery (as mentioned), Adblock Plus, Eraser. I don't think LastPass would be involved. The cache is emptied automatically every time the browser closes. "Query OCSP responder servers", Hardware acceleration" and "Tell sites I do not want to be tracked" are unclicked.

Edit: I forgot to mention that I use ESET NOD32 antivirus.

Изменено tianneis

more options

See what happens in the Firefox SafeMode.

more options

For some reason, my original query was divided into 2 different posts with the same question. (Perhaps you could eliminate the second one, or combine them, in order to avoid confusion). In fact, safe mode was one of the first things I tried, but my answer to this suggestion was on the "other" post as follows:

I tried Safe Mode in Firefox, and the site was not blocked. However, instead of https://support.mozilla.org/, it continuously came up as https://support.mozilla.org/en-US/. In safe mode I could not access add-ons, so I closed and opened the browser again normally, disabling all extensions (I don't have very many). Then I enabled them one by one, and each time tried entering the site for Mozilla Support. After each one, the site page showed fully, but the address that came up was always https://support.mozilla.org/en-US/. As soon as I enabled Ghostery, only https://support.mozilla.org/ appeared on the address line, and the page was once more blank. This happened even after I whitelisted https://support.mozilla.org/ on Ghostery. So I suppose it does have to do with this extension (I apologize to the-edmeister about this, but the first time I disabled Ghostery, nothing changed).

more options

The support site detects the preferred language sent by Firefox and redirects. Why would Ghostery block that??

more options

Perhaps because English is the preferred language, but my locality is Italy? Just wondering if that might be an issue.

more options

I think all support.mozilla.org requests should be directed to a URL that includes a locale. In other words, it should never be reached and may very well be displayed as a blank page when stripped from the locale by some extension.