X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

FireFox 39 Incompatible with All Cisco Devices

Размещено

With the latest update access to all Cisco devices via FireFox is no longer supported. I am now receiving the following errors:

Secure Connection Failed An error occurred during a connection to [IP]. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

Is there a way to roll-back the version to avoid this or a permanent fix? FireFox is currently the only browser that works very well with Cisco devices and now it will not work at all.

With the latest update access to all Cisco devices via FireFox is no longer supported. I am now receiving the following errors: Secure Connection Failed An error occurred during a connection to [IP]. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Is there a way to roll-back the version to avoid this or a permanent fix? FireFox is currently the only browser that works very well with Cisco devices and now it will not work at all.

Выбранное решение

What if you set both of these to false in about:config:

security.ssl3.dhe_rsa_aes_128_sha security.ssl3.dhe_rsa_aes_256_sha

Are you able to connect with those ciphers disabled?

Прочитайте этот ответ в контексте 12

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36

Дополнительная информация

FredMcD
  • Top 10 Contributor
4274 решений 59937 ответов
Размещено

With the newest Firefox, some Security Certificates have been disabled because of issues with new mal-ware. Can you check with the site on what Security Certificates they are using? (SSL and TSL encryption protocols)

https://developer.mozilla.org/en-US/Firefox/Releases/37/Site_Compatibility#Security

With the newest Firefox, some Security Certificates have been disabled because of issues with new mal-ware. Can you check with the site on what Security Certificates they are using? (SSL and TSL encryption protocols) https://developer.mozilla.org/en-US/Firefox/Releases/37/Site_Compatibility#Security
guigs 1072 решений 11697 ответов
Размещено

This is to ensure that you are not vulnerable to the logjam security exploit when you are browsing the internet. There are add ons to disable this change in algorithm support, but they are not secure. For example: https://support.mozilla.org/en-US/questions/1063850

This is to ensure that you are not vulnerable to the logjam security exploit when you are browsing the internet. There are add ons to disable this change in algorithm support, but they are not secure. For example: https://support.mozilla.org/en-US/questions/1063850
jscher2000
  • Top 10 Contributor
8800 решений 71980 ответов
Размещено

Выбранное решение

What if you set both of these to false in about:config:

security.ssl3.dhe_rsa_aes_128_sha security.ssl3.dhe_rsa_aes_256_sha

Are you able to connect with those ciphers disabled?

What if you set both of these to false in about:config: security.ssl3.dhe_rsa_aes_128_sha security.ssl3.dhe_rsa_aes_256_sha Are you able to connect with those ciphers disabled?
Размещено

Полезный ответ

pk0611 said

With the latest update access to all Cisco devices via FireFox is no longer supported. I am now receiving the following errors: Secure Connection Failed An error occurred during a connection to [IP]. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Is there a way to roll-back the version to avoid this or a permanent fix? FireFox is currently the only browser that works very well with Cisco devices and now it will not work at all.

That took care of the issue, disabling the ssl items noted, thank you!

''pk0611 [[#question-1071500|said]]'' <blockquote> With the latest update access to all Cisco devices via FireFox is no longer supported. I am now receiving the following errors: Secure Connection Failed An error occurred during a connection to [IP]. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Is there a way to roll-back the version to avoid this or a permanent fix? FireFox is currently the only browser that works very well with Cisco devices and now it will not work at all. </blockquote> That took care of the issue, disabling the ssl items noted, thank you!
jscher2000
  • Top 10 Contributor
8800 решений 71980 ответов
Размещено

Thank you for the confirmation!

Thank you for the confirmation!