X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Firefox 39.0 fails to auto-complete login on a site with autocomplete=off

Размещено

Following weekend updates to FF 39.0 and Flash, one site does not autocomplete login details. It did before. I have deleted it's cookies and password, changed the password, but the FF 'remember new password' box never appears.

I tried the 'remember password' bookmark: this detected and reset the 2 fields and filled in a new password in FF (but not my username) despite the expected 'remember' box not appearing. Login still fails to autocomplete.

The site HTML contains autocomplete=off for the username and password fields. I understand that this was added by the site IT team in a very recent (simultaneous?) update 'to improve security'. Firefox is (was?) supposed to ignore this and prompt the user to save.

Other sites (eg banks with 'off' set) still autocomplete OK (though I have not changed any passwords on these). Is it FF39, have I missed something, or could the site have another trap set?

Following weekend updates to FF 39.0 and Flash, one site does not autocomplete login details. It did before. I have deleted it's cookies and password, changed the password, but the FF 'remember new password' box never appears. I tried the 'remember password' bookmark: this detected and reset the 2 fields and filled in a new password in FF (but not my username) despite the expected 'remember' box not appearing. Login still fails to autocomplete. The site HTML contains autocomplete=off for the username and password fields. I understand that this was added by the site IT team in a very recent (simultaneous?) update 'to improve security'. Firefox is (was?) supposed to ignore this and prompt the user to save. Other sites (eg banks with 'off' set) still autocomplete OK (though I have not changed any passwords on these). Is it FF39, have I missed something, or could the site have another trap set?

Дополнительные сведения о системе

Установленные плагины

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • npFFApi

Приложение

  • Firefox 39.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:39.0) Gecko/20100101 Firefox/39.0
  • URL поддержки: https://support.mozilla.org/1/firefox/39.0/WINNT/en-US/

Расширения

  • Flagfox 5.1.0 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Mozilla Archive Format 3.0.3 ({7f57cf46-4467-4c2d-adfa-0cba7c507e54})
  • AVG Security Toolbar 18.5.0.909 (avg@toolbar) (Неактивно)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Неактивно)
  • ZoneAlarm Security Engine 1.5.393.22 ({FFB96CC1-7EB3-449D-B827-DB661701C6BB}) (Неактивно)

Javascript

  • incrementalGCEnabled: True

Графика

  • adapterDescription: Mobile Intel(R) 945 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x27a2
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00901025
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 2-11-2008
  • driverDate2:
  • driverVersion: 7.14.10.1437
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Изменённые настройки

Разное

  • User JS: Нет
  • Доступность: Нет
guigs 1072 решений 11697 ответов
Размещено

I do not think it is supposed to ignore this, it looks like there are some bug dependencies:

Here is what I was looking for, version 38+ -> https://developer.mozilla.org/en-US/d.../form#attr-autocomplete

I do not think it is supposed to ignore this, it looks like there are some bug dependencies: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1061630]' Here is what I was looking for, version 38+ -> [https://developer.mozilla.org/en-US/docs/Web/HTML/Element/form#attr-autocomplete]
FredMcD
  • Top 10 Contributor
4269 решений 59868 ответов
Размещено

Warning. There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a Form Filling add-on.

'''Warning.''' There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the '''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]''' {web link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a '''Form Filling add-on.'''
cor-el
  • Top 10 Contributor
  • Moderator
17577 решений 158993 ответов
Размещено

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

You can also check the log in form in the Inspector to see if there are more possibly hidden input fields present that might confuse Firefox, The password field need to be below the name input field with no other input fields in between).

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode" ---- You can also check the log in form in the Inspector to see if there are more possibly hidden input fields present that might confuse Firefox, The password field need to be below the name input field with no other input fields in between). *https://developer.mozilla.org/Tools/Page_Inspector
negtrick 1 решений 2 ответов
Размещено

It is normal behavior, like gigs said: https://developer.mozilla.org/en-US/d.../form#attr-autocomplete

But I think it's not normal that FF doesn't update autocomplete setting after it had been modified by a script or Firebug, so I asked: https://support.mozilla.org/en-US/questions/1076354

It is normal behavior, like gigs said: https://developer.mozilla.org/en-US/d.../form#attr-autocomplete But I think it's not normal that FF doesn't update autocomplete setting after it had been modified by a script or Firebug, so I asked: https://support.mozilla.org/en-US/questions/1076354