Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Clicked tabs show a glitchy page that is mostly the previously open tab.

  • 5 ответов
  • 2 имеют эту проблему
  • 35 просмотров
  • Последний ответ от jscher2000

more options

Sometimes, when I click on a tab (or otherwise navigate tabs, e.g. Ctrl+Tab), the page doesn't seem to change at first. The tab looks odd (overlapping, etc.). You can see parts of the page after hovering over them, like buttons, and the whole page sometimes comes up after a few seconds. Going to a different tab fixes the problem, although going back to the same tab usually brings the issue back, but it stops after a few times of going back and forth.

I can upload a screenshot tomorrow.

All Replies (5)

more options

Update your Flash Player Version 17.0.0.188
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

more options

I have this problem too!

more options

renan_ said

I have this problem too!

Did turning off hardware acceleration (using the instructions listed above) work? This has worked for other people who have had the same issue.

more options

Não adianta no meu caso! desmarquei e piorou mais ainda!

more options

Hi tech_hutch, at least one bug related to tab content not being painted correctly will be fixed in an upcoming Firefox 38.0.5 release. It was scheduled for next week (Tuesday, June 2), but these things sometimes slip a bit.

If this doesn't appear very often, you might find it simplest to force Firefox to "repaint" the tab rather than make a lot of settings changes. A couple ways to do this are:

  • change zoom level, for example Ctrl+ followed by Ctrl-
  • change the window size, for example, maximize or restore
  • maybe switch to another window and back, for example, Alt+Tab then Alt+Tab

One possible workaround is to disable the "off main thread composition" (OMTC) feature as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false

However, I read in a bug report that this causes problems with the HTML5 player on YouTube, if hardware acceleration is disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/