Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I make Firefox close all tabs when I exit and show only my home page when I start a new session?

  • 4 ответа
  • 2 имеют эту проблему
  • 170 просмотров
  • Последний ответ от jghuston

more options

I am running Firefox 37.0.1 on Windows 7. When I launch Firefox, it opens with all the tabs from my previous session. I would like it close all tabs when I exit, and open only my home page when I start a new session. In Options, under the General tab, I have selected the option to show my home page when Firefox starts, but it does never opens on my home page. It always displays tabs from the previous session. What am I missing?

Все ответы (4)

more options

Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display. Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want displayed.

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

more options

Sometimes add-ons or other external software will create or edit an optional settings file named user.js with a command that overrides your startup setting. This article describes how to check for a user.js file in your currently active Firefox settings (profile) folder: How to fix preferences that won't save.

Note: If you find a file named user that is of type JScript, that is the user.js file, but Windows is hiding the .js extension. You can turn off hiding of file extensions using the steps in this support article: http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions.

One other possible explanation is that Firefox is crashing during shutdown and doing a crash recovery at startup. Usually, though, that wouldn't happen every single startup...

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

Note that you shouldn't edit this value, but remove the user.js file because the normal use of this pref is to make it possible to restart Firefox after installing an extension or with applying an update.

Изменено cor-el

more options

Thanks for the help. Removing the user.js file has indeed solved the issue. I never would have solved this without your help. Thanks again.