Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am unable to login to my firewall/router. "I understand the Risks" is not fully functioning for me

  • 9 ответов
  • 20 имеют эту проблему
  • 227 просмотров
  • Последний ответ от cor-el

more options

I am running OSX 10.10.2

I have upgraded from FF v35.0.1 to v36.0.4 I receive a "This connection is Untrusted" message, and I am no longer able to Bypass the warning message to my router, and therefore I am unable to login to the router's management functions, using FireFox. Neither HTTP nor HTTPS connections will work. I have a Juniper SSG 140 router with an old and out of date certificate.

Firefox shows the following technical details: An error occurred during a connection to 192.168.X.Y.

Peer's Certificate issuer is not recognized. 

(Error code: sec_error_unknown_issuer)

When I click on the "Add Exception" button, nothing happens... There is no text describing the problems of this site, and there is no button displayed to "Confirm Security Exception"

Help?

Все ответы (9)

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Thank you for your reply FedMcD, however it did not work.

I am able to connect normally to the internet successfully, just not my router as I described above. I am using the most recent version of Norton Security, and I have turned off all firewall, AV, web settings... no difference I used your about:preferences#advanced suggestion, no difference I also tried to setup a certificate exception, and was unable as I originally described. I cleared the FF cache... no difference I do find a valid Juniper certificate but certificate at the router IP address is listed as UNKNOWN.

I also have succeeded in Logging in to the Router with HTTP, however a secured connection via HTTPS is not working and I cannot provide an exception for it?

Any other ideas?

Изменено Renate242

more options

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • inspect the certificate via the "View..." button
more options

Pull out the power cord to the modem. Do a slow count to ten. Now plug it back in. It will take a few minutes for the modem to reboot.

If you are still having problems, check with your ISP.

more options

Let me try to summarize the problem that I find with FireFox v36.0.4 one more time.

I am running OSX 10.10.2. I am able to connect to the Internet successfully and all Internet functionality of the browser appears to be working without problems.

However, when I attempt to connect to my router over my local area network via HTTPS I am unable to connect using v37.0.1 while v35.0.1 works just fine. My router is set to accept admin connections only via HTTPS, which is the configuration for the router that I want to keep in place.

When I attempt to login to the router I receive the following messages: "This connection is Untrusted”. Firefox shows the following technical details: An error occurred during a connection to 192.168.X.Y. Peer's Certificate issuer is not recognized. (Error code: sec_error_unknown_issuer). I believe that there is a valid Juniper Certificate on the router.

I attempt to bypass the problem by setting up an exception for the router. When I click on the "Add Exception" button, nothing happens... There is no text describing the problems of this site, and there is no button displayed to "Confirm Security Exception". v35.0.1 allowed me to establish an exception, v37.0.1 does not.

I have tried many things including clearing the cache and cookies, reinstalling FireFox, etc. to no avail. I have followed other recommendations for other forum members and nothing works, is this just a bug, and will it ever get fixed?

For now I guess that I will have to roll back to 35.0.1

Изменено Renate242

more options

cor-el said

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field type/paste the URL of the website
  • retrieve the certificate via the "Get certificate" button
  • inspect the certificate via the "View..." button


Sorry did not work. Any other ideas?

more options

Who is the issuer of the certificate?

You would have to install the root certificate and possible intermediate certificates in Firefox to make this work. You can check the certificate chain in other browsers and if possible export missing certificates and import them in Firefox.

  • Tools > Options > Advanced > Certificates: View Certificates > Authorities
more options

The router is Juniper, the certificate is Juniper Networks, Inc.

But my objective is not to chase down and install certificates, since the router is under my control and is clearly trusted. I would however just like to provide an exception for accessing it for admin functions without having to do anything else. It seems to me that the problem is somewhere within FF that does not allow me to make an exception when using HTTPS for my own hardware. As I say it worked just fine in v35.0.1 and prior.

Thanks for your help.

more options

It is possible that Juniper is providing a root certificate, but has only installed this certificate in the Windows certificate store. Firefox uses its own certificate store and won't work therefore. You can check the certificate chain in other browsers that work like IE or Google Chrome and export the root certificate. You can import this root certificate in the Firefox Certificate Manager under the Authorities tab. Set this bits when prompted to make it possible to use the certificate as a trusted root certificate for identifying web servers.