X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Why can't I set Flash to Always Activate suddenly in Firefox 36 beta 6?

Размещено

I am running Xubuntu 14.10. As you know, Adobe is no longer offering Flash upgrades past 11.2.202.xxx, only security updates. Thus Flash is always being marked as needing to be updated. Now up to Firefox 36 beta 5, it allowed me to set always activate in the plugins section of Add-Ons. Now however, it won't let me do this & my only options are never activate or ask to activate. It is a pain in the butt to always have to say yes, and while I DO click on the Activate & remember button, some sites still pop that up from time to time.

I must also point out Firefox 35.0.1 works correctly & let's me set it to Always activate. Is this gonna be permanent, or is it temporary? And is there any way perchance Mozilla could lean on Adobe to do for Mozilla like it's doing for Google Chrome with it's pepper-flash, which works in Linux as well as windows? ;)

Okay, I know the last question is probably impossible, but had to ask.

Thanks for any help you might have to offer.

I am running Xubuntu 14.10. As you know, Adobe is no longer offering Flash upgrades past 11.2.202.xxx, only security updates. Thus Flash is always being marked as needing to be updated. Now up to Firefox 36 beta 5, it allowed me to set always activate in the plugins section of Add-Ons. Now however, it won't let me do this & my only options are never activate or ask to activate. It is a pain in the butt to always have to say yes, and while I DO click on the Activate & remember button, some sites still pop that up from time to time. I must also point out Firefox 35.0.1 works correctly & let's me set it to Always activate. Is this gonna be permanent, or is it temporary? And is there any way perchance Mozilla could lean on Adobe to do for Mozilla like it's doing for Google Chrome with it's pepper-flash, which works in Linux as well as windows? ;) Okay, I know the last question is probably impossible, but had to ask. Thanks for any help you might have to offer.

Выбранное решение

If you run the latest Flash 11.2.202.442 version for Linux then you can ignore this. I don't think that the plugin check website takes the Linux OS into account, but merely checks the version number.

Прочитайте этот ответ в контексте 1

Дополнительные сведения о системе

Установленные плагины

  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Gecko Media Player 1.0.9Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • Helix DNA Plugin: RealPlayer G2 Plug-In Compatible version 0.4.0.5174 built with gcc 4.1.2 on Oct 6 2009
  • Next Generation Java Plug-in 10.76.2 for Mozilla browsers
  • Shockwave Flash 11.2 r202
  • 4.0.51204.0
  • Version 2.2.0-pre2 Weatherwax, copyright 1996-2012 VideoLAN and Authorshttp://www.videolan.org/vlc/

Приложение

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0

Дополнительная информация

cor-el
  • Top 10 Contributor
  • Moderator
17517 решений 158410 ответов
Размещено

Выбранное решение

If you run the latest Flash 11.2.202.442 version for Linux then you can ignore this. I don't think that the plugin check website takes the Linux OS into account, but merely checks the version number.

If you run the latest Flash 11.2.202.442 version for Linux then you can ignore this. I don't think that the plugin check website takes the Linux OS into account, but merely checks the version number. *http://www.adobe.com/special/products/flashplayer/fp_distribution3.html
Размещено

Задавший вопрос

It's not the check for updates page, it's the plugins page in Add-Ons where it shows you what plugins you have installed. Like in the picture, I can have it set to Ask to activate, as it is right now, but the Always activate option is gone, so it's either ask or not. ;)

Firefox 36 beta 5 still works, as does Firefox 35.0.1. I thought maybe something went wrong when I compiled it so I downloaded the official Firefox 36 beta 6 & tried it. Same problem. Tried restarting in safe mode, same thing. 36 beta 6 won't let me set it to always activate, Firefox 35.0.1 will.

It's not the check for updates page, it's the plugins page in Add-Ons where it shows you what plugins you have installed. Like in the picture, I can have it set to Ask to activate, as it is right now, but the Always activate option is gone, so it's either ask or not. ;) Firefox 36 beta 5 still works, as does Firefox 35.0.1. I thought maybe something went wrong when I compiled it so I downloaded the official Firefox 36 beta 6 & tried it. Same problem. Tried restarting in safe mode, same thing. 36 beta 6 won't let me set it to always activate, Firefox 35.0.1 will.
Размещено

Задавший вопрос

Okay, it turned out to be a bad profile. I renamed my .mozilla folder to .mozilla-BU and let Firefox beta make a new one & re-installed all my extensions & themes and now it's letting me set it to always activate. ;)

Still can't figure out why it was working with the current 35.0.1 but messing up on 36 beta 6 though. Seems if you were using the same profile on both browsers that both would have the same results. Oh Well. It's solved now, so thanks for the help. ;)

Okay, it turned out to be a bad profile. I renamed my .mozilla folder to .mozilla-BU and let Firefox beta make a new one & re-installed all my extensions & themes and now it's letting me set it to always activate. ;) Still can't figure out why it was working with the current 35.0.1 but messing up on 36 beta 6 though. Seems if you were using the same profile on both browsers that both would have the same results. Oh Well. It's solved now, so thanks for the help. ;)