X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

I have downloaded several times but the VLC 2.1.5 VLC web plugin version 2.1.3 has been , how do I update it?

Размещено

I downloaded it on my pc VLC media player 2.1.5 , but when I went to see the updates of the plugin , the plugin vlc web remained at version 2.1.3 how do I update the plugin?

I downloaded it on my pc VLC media player 2.1.5 , but when I went to see the updates of the plugin , the plugin vlc web remained at version 2.1.3 how do I update the plugin?

Выбранное решение

I stand corrected....the 2.1.3 plugin is flagged as "vulnerable" whenever I run my Plugin Check, and in need of an update....even though I've already updated the player to 2.1.5.

Again...how do I fix this??

Прочитайте этот ответ в контексте 27

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0

Дополнительная информация

guigs 1072 решений 11697 ответов
Размещено

It looks like only older versions are blocked in the addon site. If I may ask do you receive this warning documented here: https://support.mozilla.org/en-US/kb/add-ons-cause-issues-are-on-blocklis...

It looks like only older versions are blocked in the addon site. If I may ask do you receive this warning documented here: [https://support.mozilla.org/en-US/kb/add-ons-cause-issues-are-on-blocklist?redirectlocale=en-US&redirectslug=Add-ons+Blocklist]
Anthony_JK 1 решений 5 ответов
Размещено

I am having the same issue....and no, it is not being blocked or flagged as unstable. The plugin is marked as ver. 2.1.3, even though the actual player is marked as the most recent (2.1.5).

Essentially, it's the same issue that VLC and Mozilla/Firefox has shared in the past.

So...is 2.1.3 the correct plugin, or is this VLC's flaw? And, how do I fix it?

I am having the same issue....and no, it is not being blocked or flagged as unstable. The plugin is marked as ver. 2.1.3, even though the actual player is marked as the most recent (2.1.5). Essentially, it's the same issue that VLC and Mozilla/Firefox has shared in the past. So...is 2.1.3 the correct plugin, or is this VLC's flaw? And, how do I fix it?
Anthony_JK 1 решений 5 ответов
Размещено

Выбранное решение

I stand corrected....the 2.1.3 plugin is flagged as "vulnerable" whenever I run my Plugin Check, and in need of an update....even though I've already updated the player to 2.1.5.

Again...how do I fix this??

I stand corrected....the 2.1.3 plugin is flagged as "vulnerable" whenever I run my Plugin Check, and in need of an update....even though I've already updated the player to 2.1.5. Again...how do I fix this??
dougjp 1 решений 22 ответов
Размещено

I imagine that either nobody bothers to check to see if their plugins are up to date, or everyone is (must be) experiencing this problem and doesn't care.

I have uninstalled and installed 2.1.5 VLC Media player multiple times, cleaned registry in between, restarted etc., thinking something must change, but its the same problem still, as described above. 2.1.3 plugin.

How to I update to the latest plugin?

I imagine that either nobody bothers to check to see if their plugins are up to date, or everyone is (must be) experiencing this problem and doesn't care. I have uninstalled and installed 2.1.5 VLC Media player multiple times, cleaned registry in between, restarted etc., thinking something must change, but its the same problem still, as described above. 2.1.3 plugin. How to I update to the latest plugin?
dgordon42 0 решений 1 ответов
Размещено

The people on the VLC support forums say that the latest VLC player is 2.1.5, but the latest VLC Web Plugin is 2.1.3, and they think that Firefox is checking for the wrong version of their Web Plugin. Dave.

The people on the VLC support forums say that the latest VLC player is 2.1.5, but the latest VLC Web Plugin is 2.1.3, and they think that Firefox is checking for the wrong version of their Web Plugin. Dave.
Anthony_JK 1 решений 5 ответов
Размещено

Полезный ответ

The problem is that VLC simply doesn't think that they are doing anything wrong, and that their plugin is correct as is, and it's Mozilla's responsiblility to correct the discrepancy.

Basically, the VLC plugin is 2.1.3, while the player is 2.1.5. The Mozilla Plugin Check is assuming that the player version should be the same as the plugin, and is unintentionally triggering the "needs update" flag, even though, according to VLC, the plugin is in its current version.

Considering that VLC won't do anything to adjust their position, perhaps Mozilla can adjust theirs??

The problem is that VLC simply doesn't think that they are doing anything wrong, and that their plugin is correct as is, and it's Mozilla's responsiblility to correct the discrepancy. Basically, the VLC plugin is 2.1.3, while the player is 2.1.5. The Mozilla Plugin Check is assuming that the player version should be the same as the plugin, and is unintentionally triggering the "needs update" flag, even though, according to VLC, the plugin is in its current version. Considering that VLC won't do anything to adjust their position, perhaps Mozilla can adjust theirs??
guigs 1072 решений 11697 ответов
Размещено

I filed this bug on Mozilla's side, could you add any information I have missed, and maybe a screenshot of the page to describe the issue a little better in the bug, this will be helpful to the bug assignee :-)

https://bugzilla.mozilla.org/show_bug.cgi?id=1097853

Thank you.

I filed this bug on Mozilla's side, could you add any information I have missed, and maybe a screenshot of the page to describe the issue a little better in the bug, this will be helpful to the bug assignee :-) https://bugzilla.mozilla.org/show_bug.cgi?id=1097853 Thank you.
dougjp 1 решений 22 ответов
Размещено

Thanks for clarifying this. Yeah I find it pretty bizarre that VLC would have a program number on some program which has components with the same program number and other components with a previous program number.

Thanks for clarifying this. Yeah I find it pretty bizarre that VLC would have a program number on some program which has components with the same program number and other components with a previous program number.
Quintox303 0 решений 2 ответов
Размещено

Полезный ответ

Ok, I have finally found a solution! To fix this issue do the following:

  1. go to this website and download and install the program.
  2. go to the vlc folder in your program files and find npvlc.dll.
  3. right click and select "open using resource hacker".
  4. inside resource hacker, go to version info and anywhere where it says 2.1.3.0, change it to 2.1.5.0.
  5. Click compile script and then go file>save as. You will have to save the file in a different location and then move it into the VLC folder manually.
  6. Open firefox and goto help>troubleshooting information. Click the show folder button.
  7. find pluginreg.dat and delete it.
  8. restart firefox.

If you do what it says above, your problem should be solved. What this process does is it firstly changes the file version of the VLC file to 2.1.5.0 and then forces firefox to re-scan for plugins. If you go to the plugins menu in the addons manager, it should be listed as VLC Web Plugin 2.1.5.0. Please fell free to uninstall resource hacker after this if you want. I hope I have helped to solve your issue :D

Ok, I have finally found a solution! To fix this issue do the following: # go to [http://www.angusj.com/resourcehacker/ this website] and download and install the program. # go to the vlc folder in your program files and find npvlc.dll. # right click and select "open using resource hacker". # inside resource hacker, go to version info and anywhere where it says 2.1.3.0, change it to 2.1.5.0. # Click compile script and then go file>save as. You will have to save the file in a different location and then move it into the VLC folder manually. # Open firefox and goto help>troubleshooting information. Click the show folder button. # find pluginreg.dat and delete it. # restart firefox. If you do what it says above, your problem should be solved. What this process does is it firstly changes the file version of the VLC file to 2.1.5.0 and then forces firefox to re-scan for plugins. If you go to the plugins menu in the addons manager, it should be listed as VLC Web Plugin 2.1.5.0. Please fell free to uninstall resource hacker after this if you want. I hope I have helped to solve your issue :D
Anthony_JK 1 решений 5 ответов
Размещено

The only issue with that solution is that according to VLC, there is no problem whatsoever with their numbering phases: 2.1.3.0 is the correct version for their plugin, and 2.1.5.0 for their player. The creator of the software has repeatedly said that they will not change a thing, and that the issue lies with Mozilla/Firefox not adjusting to *their* sequencing.

Nevertheless, if this solution does resolve the problem of pinging for updates, it's worth a try.

The only issue with that solution is that according to VLC, there is no problem whatsoever with their numbering phases: 2.1.3.0 ''is'' the correct version for their plugin, and 2.1.5.0 for their player. The creator of the software has repeatedly said that they will not change a thing, and that the issue lies with Mozilla/Firefox not adjusting to *their* sequencing. Nevertheless, if this solution does resolve the problem of pinging for updates, it's worth a try.

Изменено Anthony_JK

guigs 1072 решений 11697 ответов
Размещено

There has been an update to the bug and wanted to ask the experts here, do tou think that this is what is happening described in this bug as well: https://bugzilla.mozilla.org/show_bug.cgi?id=1089012

There has been an update to the bug and wanted to ask the experts here, do tou think that this is what is happening described in this bug as well: https://bugzilla.mozilla.org/show_bug.cgi?id=1089012
donny42 0 решений 2 ответов
Размещено

Quintox303 solution. This worked for me. Don

Quintox303 solution. This worked for me. Don

Изменено donny42

donny42 0 решений 2 ответов
Размещено

Quintox303 solution worked. Don

Quintox303 solution worked. Don
inosent 0 решений 4 ответов
Размещено

Quintox303 solution worked for me, but the 2.1.3 plugin is still referenced on the addon page. I set it to 'never activate' but for the record, it is still there.

Quintox303 solution worked for me, but the 2.1.3 plugin is still referenced on the addon page. I set it to 'never activate' but for the record, it is still there.
dougjp 1 решений 22 ответов
Размещено

I think its hilarious that after 6 weeks (!) of two large organizations having this pi$$ing contest at the expense of all their customers, a third party individual has to be the one to solve this truly meaningless problem.

How is this even possible to have happen? The only way to stop the arrogance is to seek alternative products, its the only language they understand. Sometimes these two organizations/children need a good boot to wake them up. Rant over.

I think its hilarious that after 6 weeks (!) of two large organizations having this pi$$ing contest at the expense of all their customers, a third party individual has to be the one to solve this truly meaningless problem. How is this even possible to have happen? The only way to stop the arrogance is to seek alternative products, its the only language they understand. Sometimes these two organizations/children need a good boot to wake them up. Rant over.
James
  • Moderator
1596 решений 11250 ответов
Размещено

It is because VLC has chosen to keep the plugin version at 2.1.3 even when the application was updated to 2.1.5.

Then of course VLC and Mozilla are claiming each other is doing it wrong since.

It is because VLC has chosen to keep the plugin version at 2.1.3 even when the application was updated to 2.1.5. Then of course VLC and Mozilla are claiming each other is doing it wrong since.
smoofmom 0 решений 1 ответов
Размещено

I tried the solution, and it didn't work for me. I still get a notice about it being blocked by Firefox. Your latest FF update is awful! I've used FF as my default browser for over 13 years, but am seriously considering switching to Comodo Dragon.

I have a Samsung Windows 8.1 desktop PC.

I tried the solution, and it didn't work for me. I still get a notice about it being blocked by Firefox. Your latest FF update is awful! I've used FF as my default browser for over 13 years, but am seriously considering switching to Comodo Dragon. I have a Samsung Windows 8.1 desktop PC.
shaggygoblin 0 решений 1 ответов
Размещено

I have the same issue. VLC Player Package is the latest version/release. This 'package' includes several of VLC's products. The Player is version 2.15 (Latest Release). The 'plugin' is 2.13 (Latest Release). It makes complete sense that they use this versioning to identify which products in the 'package' have been changed/updated. I have a second PC that has the VLC Plugin but not the Player installed and it's working as intended. This reinforces that they are two different products and should not be versioned together. Mozilla should be checking the plugin version against the latest release of the plugin, not the Package or Player. This is clearly on Mozilla to ensure they are performing checks against the correct item. If Mozilla is confident that the plugin is out of date, perhaps Mozilla can point us to the updated plugin?

I have the same issue. [http://www.videolan.org/vlc/download-windows.html VLC Player Package] is the latest version/release. This 'package' includes several of VLC's products. The Player is version 2.15 (Latest Release). The 'plugin' is 2.13 (Latest Release). It makes complete sense that they use this versioning to identify which products in the 'package' have been changed/updated. I have a second PC that has the VLC Plugin but not the Player installed and it's working as intended. This reinforces that they are two different products and should not be versioned together. Mozilla should be checking the plugin version against the latest release of the plugin, not the Package or Player. This is clearly on Mozilla to ensure they are performing checks against the correct item. If Mozilla is confident that the plugin is out of date, perhaps Mozilla can point us to the updated plugin?
Bitter Sylence 0 решений 2 ответов
Размещено

Quintox303 worked for me. Ugh. Getting pretty tired of Moz/Fox. Now if I can only figure out whey the animated bing homepage will not work using FF, as it did in the past. IE does with no problem.

Quintox303 worked for me. Ugh. Getting pretty tired of Moz/Fox. Now if I can only figure out whey the animated bing homepage will not work using FF, as it did in the past. IE does with no problem.

Изменено Bitter Sylence

dougjp 1 решений 22 ответов
Размещено

Aha! Finally after all these months of intentionally aggravating their customers, VLC has decided to update a bundled product which has as a component, a Firefox Plugin, with the same version number as the overall product! Like they have done, except for the last version, for years! Thus ends the p!$$!ng contest they started with Mozilla! And Mozilla isn't completely without blame either, being unable to differentiate a plug in version as being current within their own search program components.

I'm only posting to publicly embarrass the people in both of these Companies who made the decisions they did. Thanks a lot for wasting all of our times - NOT.

Aha! Finally after all these months of intentionally aggravating their customers, VLC has decided to update a bundled product which has as a component, a Firefox Plugin, with the same version number as the overall product! Like they have done, except for the last version, for years! Thus ends the p!$$!ng contest they started with Mozilla! And Mozilla isn't completely without blame either, being unable to differentiate a plug in version as being current within their own search program components. I'm only posting to publicly embarrass the people in both of these Companies who made the decisions they did. Thanks a lot for wasting all of our times - NOT.