Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Firefox Hello: microphone not working when receiving a call

  • 7 ответов
  • 3 имеют эту проблему
  • 74 просмотра
  • Последний ответ от RedCucumber

more options

When I invite someone to a Firefox Hello call, my microphone doesn't seem to work.

I've established that:

  • I can hear and see my interlocutor who receives the invitation just fine
  • Microphone works normally on WebRTC sites
  • In fact, when I call myself via Hello, I can hear myself if the hello.firefox.com page is allowed to use the microphone and the audio is not muted. Unfortunately, I don't have anyone who would consider installing the Beta to make a test call but I suspect it would work as well, because why not?
  • But when I send the invitation and then accept the incoming call via the widget that appears, my interlocutor can't hear me. I don't have a webcam, so I can't test video.

I don't see any messages in the stderr output. I used to see a message "WARNING: no real random source available", installed haveged and now it no longer appears, but the microphone problem wasn't solved. Unfortunately, I don't know how to diagnose the problem further.

Изменено RedCucumber

Все ответы (7)

more options

Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. Look thru all the menu items and check all of the settings.

more options

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can inspect and manage permissions for all domains on the about:permissions page.

more options

OK, I've already got two replies telling me how to change website permissions. But my problem is not with a website. All websites work fine. My problem is with the Firefox Hello widget.

If it can be solved by changing permissions for some page, please at least give me the URL of this page.

Изменено RedCucumber

more options

So this is not a web site, but a comm program? Is it part of Firefox? An add--on? Separate program? See if it has it's own settings.

Ahh. I found it. I hadn't known about this.

http://www.bing.com/search?q=Firefox%20Hello

more options

http://www.internetnews.com/blog/skerner/firefox-hello-not-working-and-mozilla-claims-the-bug-is-invalid.html

Mozilla announced the Firefox 34 Beta release on October 17 and a key highlight is the new Firefox Hello feature. Firefox Hello is supposed to enable users to simply use the browser to be able to call each other.

It's a feature that leverages the emerging WebRTC standard and a feature that I was very eager to try out.

Problem is it, that it didn't work on the first try.

So I tried again on Mac and then again on a Windows machine too (my first try is always Linux) and still no dice. The feature just didn't show up.

Изменено FredMcD

more options

>So I tried again on Mac and then again on a Windows machine too (my first try is always Linux) and still no dice. The feature just didn't show up.

This problem, fortunately, should be easier to solve, as indicated here: https://bugzilla.mozilla.org/show_bug.cgi?id=1083525

In about:config set loop.throtted to false. Then go into the menu palette and it should be there or among the panels that can be added through "Customize".

Though some people report they had to Restore Defaults in the customization dialog or make a new profile altogether.