Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I stop Firefox from thinking it crashed and doing a recovery when forced to use Windows Task manager to close a bad URL that I never want to go back to?

  • 4 ответа
  • 3 имеют эту проблему
  • 1646 просмотров
  • Последний ответ от afcl2896

more options

Long question, I know :~) There are web sites that I may visit that will not allow me to exit the site, so I use Alt-Ctrl-Del in Windows to start the Task Manager and force the site to close by ending the program. The new version of Firefox (31.0) thinks that Firefox crashed and send me right back to the source of my problem.

Your documentation for this process is as follows:

After a crash

Due to unexpected issues such as problems with a website, software errors, or an accidental loss of power, Firefox may unexpectedly close. In these situations, Firefox can restore the pages that you were visiting when it is restarted. Firefox will automatically restore your previous session, the first time you launch it after a crash.

If Firefox crashes a second time, the Restore Session (i.e. "Well, this is embarrassing") page will appear when you next launch Firefox.

...and this is what I found trying to stop this process. Next, when I am forced to use Task Manager to close Firefox a second time to stop a badware site, then the 'Well this is embarrassing' dialog appears and I am finally safely away from the URL.

I do not want Firefox automatically sending me back to a problem site.

Thank you for any procedure you can suggest to stop Firefox from restoring problem web pages, Art Clapton

Выбранное решение

these "exit-traps" operate via javascript - if you disable javascript they become non-functional and you can simply close the page without any popups or other hassles.

in case you don't want a session to be restored after a crash, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.resume_from_crash. double-click it and change its value to false.

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

hello art, a different avenue to explore is to get out of this site without force-closing the browser.

for example once this happens, you can press f12 to bring up the developer console - on the top left click on its settings icon, which will provide you with an option to disable javascript temporarily (see screenshot). this should allow you to navigate away from the site in question.

more options

I am unwilling to attempt navigation away from these sites. The pop-ups that occur on the attempt to leave a site or to close the browser are exit traps offering incentive to stay.

Once upon a time, when the internet was less dangerous, I would be willing to close the exit pop-ups. Now, after twice being infected with malware trying to close the pop-ups, I now force close whichever browser I am using.

Recently, I clicked on the red X to close one pop-up, and it installed a trojan that I had to pay to be removed. When I clicked on 'Leave' in another exit pop, it didn't exit and it turned out I was giving permission to run a script file. Now that criminals have learned these exit pop-ups can be used to force a click action, the sites using them have become dangerous.

If I force the browser to close using Task manager, Please tell me how to stop FireFox from sending me directly back to the same site because it mistakenly believes it crashed when it did not. I forced it to close because I was on a site that had taken control of my browser and was not allowing me to leave the site.

No other browser sends me back to the potentially dangerous sites. I prefer Firefox, but the new version must have a setting that allows me to get safely away from a problem site?

Изменено afcl2896

more options

Выбранное решение

these "exit-traps" operate via javascript - if you disable javascript they become non-functional and you can simply close the page without any popups or other hassles.

in case you don't want a session to be restored after a crash, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.resume_from_crash. double-click it and change its value to false.

more options

Thank you for your help.

I clicked on the reply as a solution, but could not click on an answer to the query as to whether the reply was helpful due to not understanding the language in the selection boxes (see attached image) - sorry about that.

Изменено afcl2896