Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Can't download diskimage:https://eshop.macsales.com/OSXCenter/XPostFacto/Framework.cfm?page=XPostFacto3.html

  • 4 ответа
  • 1 имеет эту проблему
  • 2 просмотра
  • Последний ответ от jscher2000

more options

Trying to download the disk image and all i get is web page full of crazy lettres characters and what nots.

Had to go to Safari to download the image.

Using the most current uptodate browsers.

Выбранное решение

Hi waltersheluk, This is possibly because the browser has no association for this file type (dmg in this case). You can take a look at the different file types and their associated actions by going to Edit -> Preferences -> Applications tab. Here you will notice a list of the content type and default action to take. If DMG is not in the list, Firefox doesnt know how to handle this file type. For now you can try to right click on the disk image link and select the 'save link as' option. Make sure the extension of the file is .dmg and it is saved as as 'All files'. Please let us know if this works for you.

For further reference, here's a link to file type action associations https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file?redirectlocale=en-US&redirectslug=Managing+file+types

Прочитайте этот ответ в контексте 👍 1

Все ответы (4)

more options

Выбранное решение

Hi waltersheluk, This is possibly because the browser has no association for this file type (dmg in this case). You can take a look at the different file types and their associated actions by going to Edit -> Preferences -> Applications tab. Here you will notice a list of the content type and default action to take. If DMG is not in the list, Firefox doesnt know how to handle this file type. For now you can try to right click on the disk image link and select the 'save link as' option. Make sure the extension of the file is .dmg and it is saved as as 'All files'. Please let us know if this works for you.

For further reference, here's a link to file type action associations https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file?redirectlocale=en-US&redirectslug=Managing+file+types

Изменено vinaykini

more options

Firefox handles downloads based on the content-type specified by the server. In this case, the server is indicating that the .dmg is a text/plain file, which Firefox knows how to display.

Of course, that content-type is incorrect. I suspect the server isn't set up with a custom content-type for .dmg and is just using the standard fall-back setting for unknown file types.

The workaround is to right-click the link > Save Link As (or equivalent on Mac).

If you have a relationship with the site, or want to help them out, you can point them to this thread. They need to add this to their Apache configuration:

AddType application/x-apple-diskimage .dmg
more options

It seems that FireFox should be the browser that can download a .dmg file without doing a right-click the link>save the link dance.

If Safari is set up to download .dmg file by the simple double click method then FireFox is somewhat in the dark ages.

Or allow me as a dedicated FireFox user to set .dmg in the downloading application preferences.

However thanks guys for solving this problem or perhaps banging this old guys head to show him how to do it. Many thanks.

more options

This has always been an issue in Firefox from before version 1.0. Mozilla knew that Internet Explorer inspected the beginning of the file's content and used that information to override the content-type specified by the server, and therefore some sites felt no need to send correct content-type headers. Nevertheless, Mozilla decided not to follow that route and I wouldn't expect that to change. Remarkably, nearly all sites get it right.