Просмотр PDF-файлов в Firefox

Firefox включает в себя встроенное средство для отображения содержимого PDF-файлов внутри окна браузера Firefox. В этой статье описано, как использовать встроенное средство для просмотра PDF-файлов, как использовать другое средство для просмотра PDF-файлов и как устранить типичные проблемы, с которыми можно столкнуться.

Использование встроенного средства для просмотра PDF

Firefox включает в себя встроенное средство для просмотра PDF, которое позволяет просматривать почти все PDF-файлы, найденные в Интернете, без использования плагина. Встроенное средство для просмотра PDF включено по умолчанию.

PDF JS

Функции панели инструментов средства просмотра PDF

  • Просмотр эскизов или структуры документа - Кнопка слева откроет боковую панель с эскизами страниц документа. Для некоторых документов также будут доступен просмотр структуры. Это позволяет легко перемещаться по длинным документам.
    PDF Thumbnails
  • Перелистывание вверх и вниз или переход непосредственно к странице - Вы можете использовать стрелки вверх и вниз, чтобы пролистать документ, или ввести номер страницы, на которую вы хотите перейти.
    PDF Pager
  • Изменение масштаба документа - Используйте кнопки + и - для увеличения и уменьшения масштаба или выберите настройки масштабирования из выпадающего меню.
    PDF Zoom
  • Полноэкранный режим или режим презентации - Щёлкните по кнопке полноэкранного режима, чтобы развернуть PDF-файл на весь экран. Нажмите клавишу ESC для выхода из полноэкранного режима.
    PDF Fullscreen
  • Печать - Щёлкните по кнопке принтера, чтобы открыть диалоговое окно настройки принтера.
    PDF Print
  • Загрузить - Щёлкните по кнопке Загрузить, чтобы сохранить PDF-файл на свой компьютер, или открыть его с помощью программы для чтения PDF.
    PDF Download
  • Копирование текущего вида - Щёлкните правой кнопкой мыши Удерживая клавишу Ctrl, щёлкните мышью. по кнопке текущего вида, чтобы открыть текущий вид в другой вкладке или окне.
    PDF Copy

Клавиатурные сочетания средства просмотра PDF

Команда Клавиатурное сочетание
Следующая страница N или K или
Предыдущая страница P или J или
Увеличить масштаб Ctrl + +command + +
Уменьшить масштаб Ctrl + -command + -
Автоматический масштаб Ctrl + 0command + 0
Повернуть документ по часовой стрелке R
Повернуть документ против часовой стрелки Shift + R

Устранение неполадок, связанных со средством для просмотра PDF

  • При открытии определенных типов PDF-файлов средство просмотра PDF может иметь проблемы с отображением шрифтов, цветов или всего документа. Если некоторые PDF-файлы отображаются некорректно или пустыми, щёлкните по кнопке загрузки на правой стороне заголовка документа, чтобы открыть его с помощью приложения по умолчанию для просмотра PDF на вашем компьютере.

Использование других средств для просмотра PDF

Если вы не хотите использовать встроенное средство для просмотра PDF, вы можете использовать плагин для просмотра PDF-файлов в Firefox или вы можете просматривать PDF файлы за пределами Firefox, используя внешнюю программу. Для получения более подробной информации прочтите статью Как отключить встроенный модуль просмотра PDF-документов и использовать другую программу.

Чтобы переключиться с встроенного средства для просмотра PDF на другое средство для просмотра PDF:

  1. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт НастройкиВ верхней части окна Firefox откройте меню Инструменты и выберите пункт НастройкиВ панели меню откройте меню Firefox и выберите пункт Настройки...В верхней части окна Firefox откройте меню Правка и выберите пункт Настройки

    Щёлкните по кнопке меню New Fx Menu и выберите НастройкиНастройки

  2. Выберите панель Приложения.
  3. Найдите Переносимый формат документа (PDF) в списке и щёлкните по записи, чтобы выбрать её.
  4. Щёлкните по стрелке раскрывающегося списка в колонке Действие для вышеуказанной записи. Запись будет отображать "Предпросмотр в Firefox", если используется встроенное средство для просмотра PDF.
    • Чтобы использовать внешнюю программу для просмотра PDF-файлов, выберите запись для PDF-приложения, которую вы хотите использовать, например, Использовать предпросмотр или Использовать Adobe Reader.
    • Для использования плагина для просмотра PDF в Firefox, выберите Использовать "Название плагина PDF" (в Firefox).
Предупреждение: Известно, что "Adobe Acrobat NPAPI Plug-in" вызывает проблемы с Firefox. Для получения более подробной информации прочтите статью PDF файлы выглядят пустыми или вызывают сообщение об ошибке на компьютере Mac

Использование плагина для просмотра PDF

Примечание: Вы не сможете использовать PDF плагин в новом 64-разрядном Firefox, который имеет ограниченную поддержку плагинов. Для получения более подробной информации прочтите статью Как понять 32-битная или 64-битная моя версия Firefox?.

Вы можете использовать в качестве PDF плагина Adobe Reader, Nitro PDF Reader или Sumatra PDF Adobe Reader, MozPlugger, или KParts plugin, если он доступен, для просмотра PDF-файлов в Firefox. Если вы установили плагин для просмотра PDF-файлов, но PDF-файлы не отображаются в Firefox, попробуйте выполнить следующие действия:

Включение PDF плагина

Ваш PDF плагин может быть отключён в Firefox. Для его включения:

  1. В верхней части окна Firefox щёлкните по кнопке FirefoxВ панели меню щёлкните по меню ИнструментыВ верхней части окна Firefox щёлкните по меню Инструменты, и затем щёлкните по Дополнения. Будет открыта вкладка Управление дополнениями. Щёлкните по кнопке меню New Fx Menu и выберите Дополнения. Будет открыта вкладка Управление дополнениями.

  2. На вкладке Управление дополнениями, выберите панель Плагины.
  3. Выберите ваш PDF плагин.
  4. Выберите Всегда включать в выпадающем меню.

Сброс действий при загрузке

  1. Откройте папку вашего профиля:

    В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  2. В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  3. Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.

  4. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход.

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке Выход Close 29

  5. Удалите (или переименуйте) файл mimetypes.rdf.

Дополнительные решения

  • Если PDF плагин поставляется в комплекте с приложением для чтения, проверьте настройки приложения, посмотрите параметры Интернета для включения плагина или для отображения PDF-файлов в браузере.

Помогла ли эта статья? Пожалуйста, подождите...

Следующие хорошие люди помогли написать эту статью: Unghost, Aleksej, nnkaz, harrierr, Anticisco. Вы тоже можете помочь - узнайте как.