Почему Java, Silverlight, Adobe Acrobat и другие плагины больше не работают?

Начиная с Firefox версии 52, выпущенной в марте 2017г. была прекращена поддержка установленных NPAPI-плагинов в Firefox, кроме Adobe Flash. Одними из таких неподдерживаемых плагинов в Firefox, даже если они установлены на вашем компьютере, являются Silverlight, Java и Adobe Acrobat. Подробную информацию можно прочитать в этом документе о совместимости.

За последние несколько лет в Firefox были реализованы разнообразные Web API, с помощью которых веб-сайты могут выполнять свои прежние функции и задачи без помощи плагинов и вероятнее всего, вы не заметите каких-либо изменений при использовании браузера.

Почему так произошло?

Интернет полон веб-сайтов, которые выходят за рамки статичных страниц и предлагают видео, музыку или игры. NPAPI-плагины, в частности Flash, помогали воплощать такие интерактивные страницы. Однако, плагины делают браузер более медленным, менее безопасным и более подверженным падениям.

На протяжении последних нескольких лет, команда Firefox усердно работала над созданием замены плагинов, называемыми Web API. Они разработаны с целью замены функций плагинов без нарушения безопасности, стабильности и быстродействия браузера.

До этого, Web API не были до конца готовы, поэтому Firefox начал переход путем загрузки плагинов вручную при их необходимости (путём их активации по щелчку мыши).

Сейчас Web API стали готовы. Многие сайты их поддерживают и вы можете просматривать почти все ваши любимые сайты без использования старых и небезопасных плагинов. Firefox присоединяется к другим современным браузерам, таким как Google Chrome и Microsoft Edge, в прекращении поддержки NPAPI-плагинов.

// Следующие хорошие люди помогли написать эту статью:Unghost, PavelkoT, Harry, Anticisco Freeman, Valery Ledovskoy. Вы тоже можете помочь - узнайте как.

Помогла ли эта статья? Пожалуйста, подождите...

Вступите в Поддержку Mozilla