Почему Java, Silverlight, Adobe Acrobat и другие плагины больше не работают? | Решение проблем

Почему Java, Silverlight, Adobe Acrobat и другие плагины больше не работают?

Поддержка NPAPI-плагинов в Firefox, кроме Adobe Flash, будет прекращена в марте 2017 года, когда будет выпущен Firefox версии 52.Начиная с Firefox версии 52 была прекращена поддержка NPAPI-плагинов в Firefox, кроме Adobe Flash.Одними из таких неподдерживаемых плагинов являются Silverlight, Java и Adobe Acrobat. Подробную информацию можно прочитать в этом документе о совместимости.

За последние несколько лет в Firefox были реализованы разнообразные Web API, с помощью которых веб-сайты могут выполнять свои прежние функции и задачи без помощи плагинов и, вероятнее всего, вы не заметите каких-либо изменений при использовании браузера.

Почему так произошло?

Интернет полон веб-сайтов, которые выходят за рамки статичных страниц и предлагают видео, музыку или игры. NPAPI-плагины, в частности Flash, помогали воплощать такие интерактивные страницы. Однако, плагины делают браузер более медленным, менее безопасным и более подверженным падениям.

На протяжении последних нескольких лет, команда Firefox усердно работала над созданием замены плагинов, называемыми Web API. Они разработаны с целью замены функций плагинов без нарушения безопасности, стабильности и быстродействия браузера.

До этого, Web API не были до конца готовы, поэтому Firefox начал переход путем загрузки плагинов вручную при их необходимости (путём их активации по щелчку мыши).

Сейчас Web API стали готовы. Многие сайты их поддерживают, и вы можете просматривать почти все ваши любимые сайты без использования старых и небезопасных плагинов. Firefox присоединяется к другим современным браузерам, таким как Google Chrome и Microsoft Edge, в прекращении поддержки NPAPI-плагинов.

У меня есть проблемы

В случае, если вы ещё не готовы к этому переходу, Firefox ESR (Extended Support Release) версии 52 сохранит поддержку данных плагинов до начала 2018 включительно. Щёлкните здесь, чтобы загрузить Firefox ESR.

Важно: 64-битная версия Firefox ESR версии 52 для Windows поддерживает только плагины Adobe Flash и Microsoft Silverlight. Если вам также нужна поддержка Java или других плагинов, выберите загрузку 32-битной версии для Windows.

Помогла ли эта статья?

Пожалуйста, подождите...

Следующие хорошие люди помогли написать эту статью: Unghost, PavelkoT, harrierr, Anticisco. Вы тоже можете помочь - узнайте как.

Дата последнего обновления: 2017-04-22

Получите поддержку для другой платформы:
Настроить эту статью

Firefox