Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

When I update Firefox, it changes all my fonts. How do I stop if from do so?

  • 6 răspunsuri
  • 2 au această problemă
  • 144 de vizualizări
  • Ultimul răspuns de ayrehead

more options

I have windows 7. I am stuck on Firefox 21.0. Each update since then has changed my fonts to the point that I can't recover them. Even when I go and re-change the fonts to what they should be, it is not correct. I have to restore my system back to 21.0 to get back the correct fonts. I have several programs that I need the fonts to correctly use them.

Soluție aleasă

I had the same problem. Thanks for the info above on how to fix it. To summarize how to fix it:

  • Open a new window in FireFox.
  • Put this in the address bar: about:config
  • You will see a list of settings.
  • Search for: layout.css.devPixelsPerPx
  • Right click that, and Modify, and enter a value such as 1.0
  • Open a new FF window and surf to any web page.
  • If the width looks ok, you are done with layout.css.devPixelsPerPx.
  • If width is not ok, modify layout.css.devPixelsPerPx to a slightly different number. On my system, I used 1.03.
  • After doing that, you may want to change your settings for font size.
  • To do that, point to Tools menu, Options, Content.

The cause of the problem is newer releases of FF had the new thing called layout.css.devPixelsPerPx and its value was not initialized properly. The problem happens to anyone who updates to the new release. It's a bug and ought to be fixed in the software.

Citește acest răspuns în context 👍 0

Toate răspunsurile (6)

more options

Hello,

To help troubleshoot this issue, can you please provide the following information

  1. You can't update to the latest Firefox 25.01 version - due to some reason (organization restrictions for instance)
  2. When you upgraded from the previous versions to Firefox 21, the font settings did not get preserved. Is that the case?
  3. Or is it that when you upgrade to Firefox 25, the font information was not preserved and hence you reverted to Firefox 21

If you could please provide this information it will be helpful for us to troubleshoot.

Thank you

more options

It is #3. Every update since 21 I have had the problem. Even when I go in and change the fonts back to what they were at 21, everything is off and bigger.

more options

Which font settings are you referring to?

Try to disable hardware acceleration in Firefox.

more options

I am referring to the default font and color setting in Firefox. Though when I update, nothing changes in the settings, all the fonts are off and way bigger than the settings. Even though I try to reduce them after updating, nothing works.

more options

Try to disable hardware acceleration in Firefox.


Try to set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 or on Windows 8 to 1.25 and if necessary, adjust layout.css.devPixelsPerPx starting with 1.0 in 0.1 or 0.05 steps (1.0 or 0.9) to make icons show correctly.

See also:

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

You can look at this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

more options

Soluție aleasă

I had the same problem. Thanks for the info above on how to fix it. To summarize how to fix it:

  • Open a new window in FireFox.
  • Put this in the address bar: about:config
  • You will see a list of settings.
  • Search for: layout.css.devPixelsPerPx
  • Right click that, and Modify, and enter a value such as 1.0
  • Open a new FF window and surf to any web page.
  • If the width looks ok, you are done with layout.css.devPixelsPerPx.
  • If width is not ok, modify layout.css.devPixelsPerPx to a slightly different number. On my system, I used 1.03.
  • After doing that, you may want to change your settings for font size.
  • To do that, point to Tools menu, Options, Content.

The cause of the problem is newer releases of FF had the new thing called layout.css.devPixelsPerPx and its value was not initialized properly. The problem happens to anyone who updates to the new release. It's a bug and ought to be fixed in the software.

Modificat în de ayrehead