Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

I have javascript enabled in FF 21 and citi.com says I don't.

  • 4 răspunsuri
  • 6 au această problemă
  • 10 vizualizări
  • Ultimul răspuns de vjwebb

more options

On my work computer (win XP), when I attempt to login to my citi account, I am taken to a page that says that javascript is not enabled. However, I do have it enabled. I have another computer running win XP and 2 others running windows 7 and they have no trouble logging into the site with Firefox. I can login with IE, Opera and Safari.

One of my own sites has a page that requires javascript and it is having no trouble detecting that javascript is on.

On godaddy.com, I can login but the domain manager isn't displaying correctly. It works on all other computers and browsers.

I brought Firefox 21 up in safe mode and citi.com still tells me I don't have javascript enabled.

I think this just started happening when I upgraded to Firefox 21.

On my work computer (win XP), when I attempt to login to my citi account, I am taken to a page that says that javascript is not enabled. However, I do have it enabled. I have another computer running win XP and 2 others running windows 7 and they have no trouble logging into the site with Firefox. I can login with IE, Opera and Safari. One of my own sites has a page that requires javascript and it is having no trouble detecting that javascript is on. On godaddy.com, I can login but the domain manager isn't displaying correctly. It works on all other computers and browsers. I brought Firefox 21 up in safe mode and citi.com still tells me I don't have javascript enabled. I think this just started happening when I upgraded to Firefox 21.

Toate răspunsurile (4)

more options

There is something weird going on with that citi.com site. It told me my browser was not allowing cookies, so I allowed session cookies for it and reloaded the page. It still insisted that no cookies were being allowed. On checking the validation I found that there are 32 errors and 14 warnings for the code of the page.

more options

You can try basic steps like these in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

I too saw the validation errors. However, what is strange is that it works fine on another XP computer with the all the same software and version levels.

more options

Thank you. But had already cleared the cache for everything (every time I went in to test). I checked the Firefox setting for the two computers against each other to make sure I hadn't missed anything and I tried safe mode -- nothing I have done has changed the results. I wouldn't find it so confusing, except that it works everywhere except on the one computer and none of the other browsers have the problem.